• 1(current)
  • 2
  • 3
  • 4
  • 5
  • 14
  •   
Broken Kodi 18.8.0 - Kodi fails to obtain images while scraping movies
#1
Kodi version: 18.8.0
Android version: 8.0.0
Device: Sony Bravia TV (running Android TV OS)

I've been running Kodi on my Android TV for many years now.  Just yesterday, I started encountering an issue where when I update my library, Kodi no longer pulls poster, fanart, actor images, etc from tmdb anymore.  The scrape does actually find the movie and adds it to my library.  It just no longer populates the images for the movie.

I've gone as far as clearing the cache for Kodi, then clearing the data, and even uninstalling and re-installing Kodi itself.  None of these steps seemed to fix the issue.  

I went through the logfile and found the following error multiple times:

2020-10-14 05:35:36.598 T:18170   ERROR: CCurlFile::Stat - Failed: Failure when receiving data from the peer(56) for http://image.tmdb.org/t/p/original/s6cgA...brjSBt.jpg
2020-10-14 05:35:37.425 T:18171   ERROR: CCurlFile::Stat - Failed: Failure when receiving data from the peer(56) for http://image.tmdb.org/t/p/original/sovBd...3UwfZF.jpg
2020-10-14 05:35:37.449 T:18180   ERROR: CCurlFile::Stat - Failed: Failure when receiving data from the peer(56) for http://image.tmdb.org/t/p/original/8vQYi...8NClqI.jpg
2020-10-14 05:35:37.659 T:18180   ERROR: CCurlFile::Stat - Failed: Failure when receiving data from the peer(56) for http://image.tmdb.org/t/p/original/bdEMd...qbzNVj.jpg

If I understand the log lines correctly, it seems that Kodi attempts to fetch a .jpg file (likely a poster, fanart, actor image, etc) from tmdb.org and fails to obtain it.

I've taken the link to one of the .jpg files and attempted to open the link in a browser on my Sony Bravia TV.  The link opens successfully in the browser on my TV.

As part of my troubleshooting, I have tried scraping the movie files with my VPN turned on, VPN turned off, and added an exception in my VPN so Kodi can bypass the VPN completely, all with the same results.

I also have Kodi running on an Android phone connected to the same Wi-Fi network.  Kodi on the phone does not experience the same issue.  On the phone, Kodi is able to scrape the movies and obtain all images just fine.  Also, I can access the internet using other functions requiring internet access from Kodi on the Sony Bravia TV.  For example, I can watch a movie trailer just fine.  So I don't believe this is a network connection issue.

I have uploaded a copy of the logfile using the Kodi Logfile Uploader.  Here is a link to the logfile:

https://paste.kodi.tv/ewozowilub

This one is a bit of a headscratcher for me.  So any assistance would be greatly appreciated.
Reply
#2
I'm having the same issue as per this morning, my log looks the same. Bunch of "ERROR: CCurlFile::Stat - Failed: Failure when receiving data from the peer(56)" lines with various image URLs. I can open the URLs normally in a browser.
Reply
#3
Also having the same issue
Reply
#4
@SBL_ , @OzPlanet

Full debug log (wiki), please.
Saying "metoo" does not really help.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
Apologies, here:

https://paste.kodi.tv/oqazovuyej.kodi
Reply
#6
(2020-10-14, 18:09)Klojum Wrote: @SBL_ , @OzPlanet

Full debug log (wiki), please.
Saying "metoo" does not really help.


HI, I'm new to kodi and I'm having exactly the same issues.

Kodi version: 18.8.0
MacOS version: Catalina 10.15.7
Device: MacBook Pro

Debug log link:
https://paste.kodi.tv/nemenudawi
Reply
#7
Save for me.
I just got an Android box "X97 Max +", and when scanning/scraping nothing shows up. I have configured the movie folder and scraper setting, but not images at all.
Text info if fetched just fine, but no images 
Thought I was going mad....
Reply
#8
having the same issue.
Reply
#9
Yep - have the same problem since this morning (GMT+1)
Reply
#10
I have the same problem since today.
i get for example logs like this:
60   ERROR: CCurlFile::Stat - Failed: Failure when receiving data from the peer(56) for http://image.tmdb.org/t/p/original/rN3By...5U81fU.jpg
Reply
#11
I have scraped 9 movies and had no problems with artwork with any of them.

If you are still having problems, provide the names of the the movies you are scraping.

I imagine the problem at TheMovieDB is temporary for your location and should fix itself. Are you all from the same general area?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#12
Yeah, same here. Did they push a new version update yesterday? I wiped Kodi clean and did a fresh install today from Google play store but same problem exists. I didn't notice if it was a newer version than what I had.
Reply
#13
(2020-10-14, 20:52)Karellen Wrote: I have scraped 9 movies and had no problems with artwork with any of them.

If you are still having problems, provide the names of the the movies you are scraping.

I imagine the problem at TheMovieDB is temporary for your location and should fix itself. Are you all from the same general area?

Well, I am in Denmark.
Don't know about the others who have reported the same.
Reply
#14
(2020-10-14, 20:59)NormanC Wrote:
(2020-10-14, 20:52)Karellen Wrote: I have scraped 9 movies and had no problems with artwork with any of them.

If you are still having problems, provide the names of the the movies you are scraping.

I imagine the problem at TheMovieDB is temporary for your location and should fix itself. Are you all from the same general area?

Well, I am in Denmark.
Don't know about the others who have reported the same.
California here.
Reply
#15
(2020-10-14, 20:52)Karellen Wrote: If you are still having problems, provide the names of the the movies you are scraping.

I imagine the problem at TheMovieDB is temporary for your location and should fix itself. Are you all from the same general area?

From Northern Europe. Changing artwork is impossible for everything in the library. It shows a number of options remote1, remote2 etc. but no actual "image preview" and the artwork is not added as usual on selection.

The failed image urls are working when accessing from a desktop browser and when using the "kodi web interface" all available images shows up and are added as thumbnails.
Reply
  • 1(current)
  • 2
  • 3
  • 4
  • 5
  • 14
  •   



Logout Mark Read Team Forum Stats Members Help
Kodi 18.8.0 - Kodi fails to obtain images while scraping movies0
This forum uses Lukasz Tkacz MyBB addons.