Solved How to force Kodi to open on specific monitor
#1
I've set the display I want in settings (Settings / System / Display / Monitor), but often Kodi changes it back to the wrong screen. Happens after I shut down the pc. Suspect it's because monitors get perhaps turned off in a certain order, causing Kodi to switch and then save on close or something...

Any way to force Kodi to a specific screen when starting it? Perhaps a command line option, or like a whitelist for screens just like there is for resolutions or something?

Can't find other solutions through google, only the Settings option, which does not work for me.
Kodi 19.1.0, Windows 10 Pro, 3 screens
Reply
#2
You settings are stored in a file called guisettings.xml this is found within your Userdata folder see https://kodi.wiki/view/Userdata

Open file and look for the videoscreen.monitor setting

In my case this is

<setting id="videoscreen.monitor">Generic PnP Monitor #1</setting>

Next you need to create a advancedsettings.xml if you don't already have one, see https://kodi.wiki/view/Advancedsettings.xml

Within the advancedsettings.xml you can add entries which force the settings to certain values when Kodi is launched, this is covered in https://kodi.wiki/view/Advancedsettings....Conversion

So in my case if I wanted Kodi to always start on Generic PnP Monitor #1 then the advancedsettings.xml would contain

<advancedsettings>
<videoscreen>
<monitor>Generic PnP Monitor #1</monitor>
</videoscreen>
</advancedsettings>
Reply
#3
(2021-06-11, 10:42)void_foo Wrote: Suspect it's because monitors get perhaps turned off in a certain order, causing Kodi to switch and then save on close
Correct; once you have lost handshaking between the chosen monitor display and PC, Kodi will go to default settings to primary. Exiting Kodi first will save your prefs for next launch as long as the listed displays are still available.  The information 'jjd-uk' offered is one of the work-rounds.
Reply
#4
Looks like it's working!

For any future googlers, I thought this didn't work at first because I had the wrong monitor in advancedsettings.xml. The number in 'Generic PnP Monitor #1' did not match the number I saw in the Windows Display Settings. Tried different number, was correct one.

Thanks!
Reply
#5
Thread marked solved.
Reply



Logout Mark Read Team Forum Stats Members Help
How to force Kodi to open on specific monitor0
This forum uses Lukasz Tkacz MyBB addons.