Kodi Community Forum

Full Version: XBMC Intro Movie
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13
OK. Trying it at work.
Movie Loads but after splash screen.
Log file looks like Splash has been set to false??

Log File:
Hypknox Wrote:Or are we talking about the startup.xml located in your skin 720p folder?
I got it to work by loading from startup.xml but I had to actually define the true location such as "C:/XBMC/addons/etc.", I was not able to get the intro movie to play with special://.

An irrelevant issue because the intro movie plays.

Now, I am having one issue that I would like to resolve if possible. Maybe others are experiencing the same thing. The "Buffering - Please Wait" dialogue box seems to pop up, only for a millisecond or so, but it's noticeable. It really takes away from the smooth/clean intro feel. I've searched around and tried a few different options such as editing dialogbusy.xml, videofullscreen.xml and adding the line <busydialogdelay>2000</busydialogdelay> in the advancedsettings.xml. Nothing seems to hide or disable this box.

Is there a way to actually disable or just hide/prevent that dialogue box from popping up? It would make for a much cleaner feel for the intro.

EDIT - Also, on the right side of the screen centered there is also a small set of controls with nothing but buttons for play, pause, ff, rw, stop it looks like. Again, this only flashes for a brief moment, but both it and the Buffering - Please wait dialogue box are rather annoying. In case it isn't clear the buffering dialogue box is located at the bottom center of the screen.
Got it working when I changed the movie file name to "Intro" and moved it to:
C:\Program Files (x86)\XBMC\addons\skin.confluence

And put:
<onload condition="Window.Previous(startup)">XBMC.PlayMedia(Special://skin/Intro.mp4)</onload>
Right under <window>

C:\Program Files (x86)\XBMC\addons\skin.confluence\720p

Made advancedsetting.xml file in notepad and saved to:

But when movie loads it has the "now playing" screen pulled up with the OSD controls. Do you guys see that too? Is there a way to get rid of that so it just looks like a splash screen?
cank, I only noticed the now playing with OSD controls pop up when I took out the dialoguebusy.xml file. When I replaced it that went away. I'm using Aeon MQ3 skin though, not confluence. I initially removed that file from the equation in an attempt to hide/disable the buffering please wait dialogue box that shows for a brief second (refer to my previous post) which I am still unsuccessful in achieving.

I took a look at confluence dialoguebusy.xml and it appears to be fairly different than Aeon MQ3.

I'm not suggesting that you change yours to match this, in fact that would most likely cause undesired results, but this is what my dialoguebusy.xml looks like for reference -

<!-- Aeon MQ 3 -->

<window id="138">
<control type="group" id="901">
<control type="label" id="401">
<control type="label" id="401">
you can test this script

your intro is inside
Require compatible skin, just Glass actualy
fmronan Wrote:you can test this script

your intro is inside
Require compatible skin, just Glass actualy

WOW...again passion XBMC has created an amazing addon...
Thanks for this...

for some reason i cannot disable splash in advanced settings... fresh instal of eden rc2 - anyone else having this problem?
never mind, got it working ok on my main machine (just not developer machine for some reason!).

Now there is a brief showing of the home menu before it boots into the intro movie.. any way to remove this? thanks

...and by the way, bloody good work. the best just got better!
And much more in "Glass", astronomy with google weather 2.0.0, widget with rss feeds, agregated feeds, mail notifier, color picker, view installer, background with submenu, etc... many ideas for skinner.Wink
fmronan Wrote:you can test this script

your intro is inside
Require compatible skin, just Glass actualy

I have installed this and sellected intro movie, but it wont start up. I can preview it via the intro settingsHuh Any suggestions? Huh
You must have the Last rev for Glass skin rev129, don't work with other skin.
I am sure I have the latest version, only installed today and I can get the add-on showing up and am able to configure it.
I installed the Glass skin because I could not get the default Splash screen to stop playing first and then the intro movie. However, in Glass I could not get the intro movie to play at all so I switched back to Confluence and the next time I started xbmc, the splash screen did not show up and the intro movie played as it should(if I do not touch the mouse, the OSD does not come up but it would be nice to be able to disable that before the home screen loads).

As to where I put the <onload condition="Window.Previous(startup)">XBMC.PlayMedi a(Special://skin/Intro.mp4)</onload>:
If I put it in Home.xml, everytime I went back to the home screen the Intro movie played so I put it in the Startup.xml file right under <window>

After it worked in Confluence I tried again in Glass but no luck. Maybe I should delete the <onload> event and my advanced settings xml to try it that way but since it's working, I will leave it for now.
this is so confusing im traying to make this work but i have no luck!!! can some one explain in plaint english how to set this up pleasee...ok this is what i did i copy this line
<onload condition="Window.Previous(startup)">XBMC.PlayMedia(special://skin/introMovie.mov)</onload> to xbmc/addon/skin.confluence/720
but have no luck getting it to work...also once i put that line do i have to go to program and change something under xbmc intro movie?...please someone write step by step on how to do this on the atv2 please
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13