Kodi Community Forum

Full Version: Universal Scraper for Music Albums
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
Multiple similarly named albums or artists are not currently supported in Frodo even with MB tags. The files will be listed under a single album.

Hopefully better MB support is on the horizon for Gotham, but we're still ironing out some wrinkles. If you're brave you can test with nightlies, but as mentioned there are known issues that might give you some library artist duplicates and scanning is slow as we're waiting on more MusicBrainz mirrors to open up in the community.
(2013-08-06, 05:58)capfuturo Wrote: [ -> ]1) I am pasting this http://www.allmusic.com/album/release/ba...0001055858 into an album.nfo inside the album folder. Then trigger a refresh but nothing happens, no new info populates the album. Same results with the Discogs' link to the particular release. Is it the allmusic link to the release inside the album.nfo what is needed according to this, isn't it? The only link that gives results, although imperfect, is the direct musicbrainz link to the release, however it brings back the general info for the release group with a review from wikipedia instead and neither from allmusic or discogs.

For the Universal Album Scraper you indeed need to link directly the MusicBrainz release page. The wiki page you linked is unfortunatelly wrong. Not sure who was creating it, I will get it fixed as soon as I find the time for it. Allmusic and Discogs link will not work. Discogs is not supported by the scraper at all, while it fills some database fields from allmusic, but only if the allmusic link is available on MusicBrainz. The ONLY supported site for 'Album Review' is theaudiodb.com (what you can edit yourself as well), so you are not getting the review from wikipedia. Once again, Album Review is not available from allmusic or last.fm or from anywhere else, only from theuadiodb.com. Not sure what you mean on imperfect thought... Confused

(2013-08-06, 05:58)capfuturo Wrote: [ -> ]2) I have 4 different releases (versions) of the album 'Bad' from Michael Jackson. When added to the library they are gathered together under one album and all tracks are mixed up. The metadata has been correctly saved differentiating each one of them by musicbrainz release year and contents, with Picard. Is there a way to avoid this, different than editing the album titles to a slightly modified name appending forms such as 're-release', 'special edition', etc...
I believe if you link the different releases from MusicBrainz via album.nfo that it should be OK, I never tested this though.

(2013-08-06, 05:58)capfuturo Wrote: [ -> ]3) Is there a way in XBMC to define a set of albums (not the filter solution), e.g., the set 'Bad', and when clicking on it, then all the releases I have for the album 'Bad' including the original will show up as individual albums for me to select? Like sets in movie collections? So I can define my own sets of music albums?

No, this is not currently possible.
(2013-08-06, 07:08)night199uk Wrote: [ -> ]Multiple similarly named albums or artists are not currently supported in Frodo even with MB tags. The files will be listed under a single album.

Hopefully better MB support is on the horizon for Gotham, but we're still ironing out some wrinkles. If you're brave you can test with nightlies, but as mentioned there are known issues that might give you some library artist duplicates and scanning is slow as we're waiting on more MusicBrainz mirrors to open up in the community.

Thanks a lot night199uk,

Your feedback on this matter has shown me a clearer picture of the current limitations of the scraper, as well as where the efforts are heading for. I look forward to trying the stable release when the time comes.

Best,

CF
I)
(2013-08-06, 09:49)olympia Wrote: [ -> ]For the Universal Album Scraper you indeed need to link directly the MusicBrainz release page. The wiki page you linked is unfortunatelly wrong. Not sure who was creating it, I will get it fixed as soon as I find the time for it. Allmusic and Discogs link will not work. Discogs is not supported by the scraper at all, while it fills some database fields from allmusic, but only if the allmusic link is available on MusicBrainz. The ONLY supported site for 'Album Review' is theaudiodb.com (what you can edit yourself as well), so you are not getting the review from wikipedia. Once again, Album Review is not available from allmusic or last.fm or from anywhere else, only from theuadiodb.com. Not sure what you mean on imperfect thought... Confused
Roger that Olympia,
Thanks for the explanations and follow-up on the wiki corrections that for sure will help many users stuck at the moment with this. The reason why it appeared as I was getting a wikipedia-scraped review is due to the fact that someone actually pasted the whole wikipedia review (and link) along with the BBC review (and link) as theaudiodb.com review for the generic album 'Bad'. That explains it. The imperfect 'thought' was just a typo, no worries.

My understanding is that a generic review of an original release should be good for all the following releases; however there are very important facts particular to some releases that could go from a regular masterisation to actual meaningful changes at the editing desk. These are usually stated as further reviews or notes to the specific releases. Theaudiodb.com doesn't seem to be purpose-designed to allocate multiple releases besides the main original release, which I think makes things easier in many ways and I support that; there is no way to scrape any other site that could have these information available also.

Knowing the above, would it be possible to add to the scraper/skin an extra field called 'Release Notes', 'Notes' or 'Comments', on the Information screen? Whom should I direct my request to? It could be located between 'Review' and 'Search on YouTube'. To save space, the latter could perhaps be shown just as 'YouTube' or 'On YouTube' ?? Alternatively, it could also be displayed on the 'full screen' under 'info' or as an extra field scrolling sideways right under 'Moods', from drop-down menu 'Extra Info' (View image below). The info presented on this notes could be any information the user would like to manually add to a tag called <notes> or <comments> (which already exist as a standard tag in many taggers) when writing the album's metada (Picard, The Tagger, etc.) or in the album.nfo if a corresponding field <notes>/<comment> is provided for this purpose, besides the url that would take care of pulling in the reviews and all extra info. These notes could contain useful technical info for the listener to look for, as you can see in the example below for 'Bad' (Reissue 1994):

<This re-issue of 'Bad' features a number of changes when compared to the original 1987 release: "Bad" has a modified horn arrangement. "The Way You Make Me Feel" has richer vocalizations and background vocals. "I Just Can't Stop Loving You" omits Michael Jackson's spoken intro. "Dirty Diana" is replaced with the 7-inch edit of the song. "Smooth Criminal" omits the dramatic breathing within the intro.>

Image

II)
(2013-08-06, 09:49)olympia Wrote: [ -> ]I believe if you link the different releases from MusicBrainz via album.nfo that it should be OK, I never tested this though.
Tried album.nfo pointing to different releases in Musicbrainz to no avail. They keep being gathered and mixed-up into one-album view. The only method that has worked for me so far is retagging each release with a manually-forced different name via Picard.

III)
1) The list of tracks on the lower-left corner whilst on 'Info view' (see image above), does it have any other practical function than showing the names of the tracks, or is it just a plain list of tracks with no possibility to select one of them for playback or extra info?
2) There is no time info (track length) for some songs (2nd song, picture above); is the scraper failing to retrieve this info for certain tracks or is this a skin display issue? Any way to fix this?
3) The presence on the album name of certain punctuation symbols such as ", stops the scraper from finding the musicbrainz release and gets back no info (e.g., see image above with 'The 12" Mixes' album). A manual refresh deleting these symbols from the album name throws 100% success. Perhaps this has been worked for the next release? If not, would it be possible for the scraper to automatically strip from the album name any known "illegal" or incompatible character before initiating the API call?

Looking forward to your reply. All best,

CF
I am hoping someone can help me with this. In my music collection each artist gets their own folder. In the artist folder, each album is a folder. I have the release year in parentheses after the title. For example: "Dark Side Of The Moon (1973)" - apparently the "(1973)" is preventing the Universal Scraper from recognizing the album and not downloading the information. If I remove the "(1973)" it does scrape the information.

I do not want to remove the "(date)" from every album (folder name) in my collection. Is there a way to get around this and have the scraper ignore the date?
(2013-08-12, 20:47)wsucoug Wrote: [ -> ]I am hoping someone can help me with this. In my music collection each artist gets their own folder. In the artist folder, each album is a folder. I have the release year in parentheses after the title. For example: "Dark Side Of The Moon (1973)" - apparently the "(1973)" is preventing the Universal Scraper from recognizing the album and not downloading the information. If I remove the "(1973)" it does scrape the information.

I do not want to remove the "(date)" from every album (folder name) in my collection. Is there a way to get around this and have the scraper ignore the date?

I Have a similar set up to wsucoug, my collection has the years in the folder name as well Wishbone Ash - (1974) There's The Rub etc, it works ok for my Squeezebox server (iPeng HD for iPad) but I would like it to work together with XBMC as well, is there any way round it or do the years have to be removed?
You guys do realize that folder name has nothing to do with scraping for music, right? Only the file tagging matters, nothing else... XBMC scan the tags from the file, doesn't look at folder/file names at all.
(2013-08-20, 20:39)olympia Wrote: [ -> ]You guys do realize that folder name has nothing to do with scraping for music, right? Only the file tagging matters, nothing else... XBMC scan the tags from the file, doesn't look at folder/file names at all.

Yes, just realised that as I am adding my music to the XBMC library, looking good so far, hopefully it will be finished tomorrow morningSmile
(2013-08-20, 20:39)olympia Wrote: [ -> ]You guys do realize that folder name has nothing to do with scraping for music, right? Only the file tagging matters, nothing else... XBMC scan the tags from the file, doesn't look at folder/file names at all.

The tag had the (date) in it "Dark Side of the Moon (1973)" and that is what was preventing it from scraping.

The new problem I have that if I go to Music ->Artist and then view by thumbnail, they are all blank.

If I right click the thumbnail and choose "Artist information" a box opens and asks me to "Enter the artist name" (and it is already correctly populated). I click "Done" and the same box appears populated. I'm in a loop. So I close the box. Now, if I right click an artist, choose "Change Scraper", on the left side of the box under "Current Scraper" nothing is populated. The two choices of Universal Artist Scraper and TheaudioDb Artist Scraper are on the right. I select Universal and click OK. Now it asks me "Do you want to refresh info for all items within this path?" I click YES. Nothing happens. I right click the artist again and select "Artist information" and it then scrapes the correct info and the thumbnail is there. I then right click the same artist and now choose "Query info for all artists" and it scans my entire library and the thumbs are still blank! #@$[email protected]

Under System -> Settings -> Music -> Library - I have Universal Artist Scraper for "Default service for artist information"

In the Settings for Universal Artist Scraper under the "Artwork" tab I have all of the items ticked except the last.fm

Am I doing something wrong? Do I not have it setup correctly?

Help.
(2013-07-29, 10:52)n1md4 Wrote: [ -> ]Hi. I have recently reinstalled XBMC to an SSD, and have my libraries across magnetic storage, on LVM. I have added music sources, and during an update, it appeared to scrape using local nfo files; no doubt from a previous install. For the most part this seems to be fine, but if I select by artist, I can't see albums. Is there a 'usual' cause for this?

There are a few problems here; missing art, missing info, even missing albums! Is there a way I can clear all the the local nfo details, and rescrape all the my music content; albums & artists online?

(2013-08-23, 00:35)n1md4 Wrote: [ -> ]
(2013-07-29, 10:52)n1md4 Wrote: [ -> ]Hi. I have recently reinstalled XBMC to an SSD, and have my libraries across magnetic storage, on LVM. I have added music sources, and during an update, it appeared to scrape using local nfo files; no doubt from a previous install. For the most part this seems to be fine, but if I select by artist, I can't see albums. Is there a 'usual' cause for this?

There are a few problems here; missing art, missing info, even missing albums! Is there a way I can clear all the the local nfo details, and rescrape all the my music content; albums & artists online?

I may have sorted this, removed the audio source, then (on Linux) # rm .xbmc/userdata/Database/MyMusic* ... 4% so we'll see.
Oh dear, I've now lost the ability to view in 'library' mode, there is no option to select this.

This is the problem I had, http://forum.xbmc.org/showthread.php?tid=66879&page=2 , and as it's not part of Universal Scraper I'll say no more on the matter Smile
Hmmm, still the original problem, there is a bunch of artwork missing, and even some of the artists don't have listed albums ..

How can I scrub all data, and add this all a-fresh? It had scraped nicely on a previous build, not sure why this one is being problematic. I'd send a debug, but there's not much to see; a.k.a. I'll attempt to manually update an album, and get an onscreen error about not being able to download, but nothing in debug log.

Assistance would be appreciated. Thanks.
(2013-08-21, 01:56)wsucoug Wrote: [ -> ]
(2013-08-20, 20:39)olympia Wrote: [ -> ]You guys do realize that folder name has nothing to do with scraping for music, right? Only the file tagging matters, nothing else... XBMC scan the tags from the file, doesn't look at folder/file names at all.

The tag had the (date) in it "Dark Side of the Moon (1973)" and that is what was preventing it from scraping.

The new problem I have that if I go to Music ->Artist and then view by thumbnail, they are all blank.

If I right click the thumbnail and choose "Artist information" a box opens and asks me to "Enter the artist name" (and it is already correctly populated). I click "Done" and the same box appears populated. I'm in a loop. So I close the box. Now, if I right click an artist, choose "Change Scraper", on the left side of the box under "Current Scraper" nothing is populated. The two choices of Universal Artist Scraper and TheaudioDb Artist Scraper are on the right. I select Universal and click OK. Now it asks me "Do you want to refresh info for all items within this path?" I click YES. Nothing happens. I right click the artist again and select "Artist information" and it then scrapes the correct info and the thumbnail is there. I then right click the same artist and now choose "Query info for all artists" and it scans my entire library and the thumbs are still blank! #@$[email protected]

Under System -> Settings -> Music -> Library - I have Universal Artist Scraper for "Default service for artist information"

In the Settings for Universal Artist Scraper under the "Artwork" tab I have all of the items ticked except the last.fm

Am I doing something wrong? Do I not have it setup correctly?

Help.

Do you just have the year in the album folder like "Pink Floyd - Dark Side Of The Moon (1973)" and have it after the track title as well because I have also the year in the album folder but I have put the year before the album name Pink Floyd - (1973) Dark Side Of The Moon and then in the folder correctly tagged track number artist - track name and there is no problem with mine, all my albums are done this way apart from compilations where I did not bother with the year, as a previous poster said it looks at the tagged names inside the album folder and the year should not present a problem...

Pink Floyd - (1973) Dark Side Of The Moon
01 Pink Floyd - Speak To Me
02 Pink Floyd - On The Run
03 Pink Floyd - Time
04 Pink Floyd - The Great Gig In The Sky
05 Pink Floyd - Money
06 Pink Floyd - Us And Them
07 Pink Floyd - Any Colour You Like
08 Pink Floyd - Brain Damage
09 Pink Floyd - Eclipse
(2013-08-23, 17:59)Jay La Funk Wrote: [ -> ]
(2013-08-21, 01:56)wsucoug Wrote: [ -> ]
(2013-08-20, 20:39)olympia Wrote: [ -> ]You guys do realize that folder name has nothing to do with scraping for music, right? Only the file tagging matters, nothing else... XBMC scan the tags from the file, doesn't look at folder/file names at all.

The tag had the (date) in it "Dark Side of the Moon (1973)" and that is what was preventing it from scraping.

The new problem I have that if I go to Music ->Artist and then view by thumbnail, they are all blank.

If I right click the thumbnail and choose "Artist information" a box opens and asks me to "Enter the artist name" (and it is already correctly populated). I click "Done" and the same box appears populated. I'm in a loop. So I close the box. Now, if I right click an artist, choose "Change Scraper", on the left side of the box under "Current Scraper" nothing is populated. The two choices of Universal Artist Scraper and TheaudioDb Artist Scraper are on the right. I select Universal and click OK. Now it asks me "Do you want to refresh info for all items within this path?" I click YES. Nothing happens. I right click the artist again and select "Artist information" and it then scrapes the correct info and the thumbnail is there. I then right click the same artist and now choose "Query info for all artists" and it scans my entire library and the thumbs are still blank! #@$[email protected]

Under System -> Settings -> Music -> Library - I have Universal Artist Scraper for "Default service for artist information"

In the Settings for Universal Artist Scraper under the "Artwork" tab I have all of the items ticked except the last.fm

Am I doing something wrong? Do I not have it setup correctly?

Help.

Do you just have the year in the album folder like "Pink Floyd - Dark Side Of The Moon (1973)" and have it after the track title as well because I have also the year in the album folder but I have put the year before the album name Pink Floyd - (1973) Dark Side Of The Moon and then in the folder correctly tagged track number artist - track name and there is no problem with mine, all my albums are done this way apart from compilations where I did not bother with the year, as a previous poster said it looks at the tagged names inside the album folder and the year should not present a problem...

Pink Floyd - (1973) Dark Side Of The Moon
01 Pink Floyd - Speak To Me
02 Pink Floyd - On The Run
03 Pink Floyd - Time
04 Pink Floyd - The Great Gig In The Sky
05 Pink Floyd - Money
06 Pink Floyd - Us And Them
07 Pink Floyd - Any Colour You Like
08 Pink Floyd - Brain Damage
09 Pink Floyd - Eclipse

Here's how mine are:

Pink Floyd - This is a folder
Dark Side Of The Moon (1973) - This is a folder
01 - Speak To Me
02 - On The Run
03 - Time
04 - The Great Gig In The Sky
05 - Money
06 - Us And Them
07 - Any Colour You Like
08 - Brain Damage
09 - Eclipse

The problem was that for the id3 tag in the "Album" field I had "Dark Side Of The Moon (1973)" Once I removed the "(1973)" from the id3 tag and rescraped, I got the cover art for all the albums. I left the actual folder like this Dark Side Of The Moon (1973). That problem was taken care of a couple of weeks ago.

Again, the new problem as I described above is that I am unable to get each artist thumbnail to scrape. This is what I am waiting for help for.
(2013-08-23, 17:47)n1md4 Wrote: [ -> ]Hmmm, still the original problem, there is a bunch of artwork missing, and even some of the artists don't have listed albums ..

How can I scrub all data, and add this all a-fresh? It had scraped nicely on a previous build, not sure why this one is being problematic. I'd send a debug, but there's not much to see; a.k.a. I'll attempt to manually update an album, and get an onscreen error about not being able to download, but nothing in debug log.

Assistance would be appreciated. Thanks.

Loads of errors when scraping .. http://www.xbmclogs.com/show.php?id=49442 Any ideas?

It would appear any thing involving SQLite errors, I've not got this installed locally, so can only guess this is server side..
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34