Kodi Community Forum

Full Version: mythicalLibrarian - a tool to build Movie and TV Show library from MythTV recordings
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey all, seems this is a simple problem, but i don't know how to make this work. Using latest svn, myth .24. Everything else passes.

All tests complete RESULTS
MythTV Database Test: ***PASSED***
Installed Packages: ***PASSED***
Notifications Test: ***PASSED***
XBMC Communications: ***PASSED***
File System Checks: ***PASSED***
mythicalTesting: COULD NOT COMPLETE
Overall mythicalReadiness: ***FAILURE***
I think I may be getting the same thing.

SEARCHING: www.TheTvDb.com SHOW NAME: mister rogers EPISODE: show 1332
/usr/local/bin/mythicalLibrarian: line 1013: /home/mythtv/.mythicalLibrarian/zap2it.txt: No such file or directory
CONFIDENCE:0 LOGIC PATH:  Attempted Match On Zap2itID: Failed; Attemted match on Standard Logic: Failed; Attemted Title match on Fuzzy Logic: Failed; Information not obtainable; Could not set Sxx and Exx, Failed;
JOB: mythicalLibrarian 'testfile.ext' 'mister rogers' 'show 1332'
TARGET SET:/home/mythtv/Showings/mister rogers/mister rogers S0E0 (show 1332 Recorded  on ).ext
exited with status 1

Granted that's the testing phase. But I got very similar results in my output.log for shows, I forgot to copy it prior to trying to update, and the output.log.old is blank. This started 2 nights ago, prior to that everything was working fine. Now every show I record ends up in the Showing directory.

Pertaining to the zap2it.txt. I did a touch on the file name, and also copied over a old copy and no go.

I was using the mythtv 0.23 mysql method, but tried the 0.24 python method and that didn't solve anything.
I'm working on it.
Fixed in SVN Revision 939

press any key to continue on to the final results...
  All tests complete           RESULTS
  MythTV Database Test: ***PASSED***
  Installed Packages:         ***PASSED***
  Notifications Test:         ***PASSED***
  XBMC Communications:       ***PASSED***
  File System Checks:         ***PASSED***
  mythicalTesting:         ***PASSED***
  Overall mythicalReadiness: ***PASSED***
-----End of diagnostics-----
TVDB changed addresses again, however they did not use a reference this time.
SVN R942 moved to stable.

Let me know if there are any problems.
Working thanks.
Btw.. I've designed the testing to be an accurate representation of an actual run. Everything from identification to communication and permissions.... even Myth database communications are tested. If testing fails, mythicalLibrarian will fail because its using all the same code with different parameters. It makes it easier to find errors. So if the diagnostics fails and there's no helpful solution provided by mythicalDiagnostics, please let me know.
Recordings Database is not used for testing.
Performing fuzzy logic lookup on database file. Please wait.
It may take a moment to build mythical librarian database files
executing mythicalLibrarian testfile.ext 'mister rogers' 'show 1332'
testing for exit status 0
/usr/local/bin/mythicalLibrarian: line 1877: mythicalLibrarian: command not found
exited with status 127
press any key to continue on to the final results...

All tests complete RESULTS
MythTV Database Test: ***PASSED***
Installed Packages: ***PASSED***
Notifications Test: ***PASSED***
XBMC Communications: ***PASSED***
File System Checks: ***PASSED***
mythicalTesting: COULD NOT COMPLETE
Overall mythicalReadiness:***FAILURE***
-----End of diagnostics-----
mythicalLibrarian has encountered an error. This may be due to
lack of network connection. If the problem persists, contact
outleradam here: http://forum.xbmc.org/showthread.php?tid=65644

These issues must be corrected in order for mythicalLibrarian to
perform correctly
Please try again. If problem persists, please post here: http://forum.xbmc.org/showthread.php?tid=65644
MythTV job not added because mythicalLibrarian already exists in slot 1
permissions were set for user: mythtv.
RSS Feed will be located at .
mythicalLibrarian is located in /usr/local/bin
mythicalLibrarian's log is located in ~/.mythicalLibrarian/output.log
Renamed video files will be placed in new folders within original.
ie. /var/lib/mythtv/recordings/Episodes, /Movies and /Showings.
Check the mythicalLibrarian checkbox when setting up recordings.
./mythicalSetup.sh: line 840: 1: command not found
For more information, type 'mythicalLibrarian --help'
Have you upgraded? TheTVDb changed it's address. Please post your ~/.mythicalLibrarian/output.log

Also, please wrap logs in code tags...
All tests complete           RESULTS
  MythTV Database Test:      ***PASSED***
  Installed Packages:       ***PASSED***
  Notifications Test:       ***PASSED***
  XBMC Communications:      ***PASSED***
  File System Checks:       ***PASSED***
  mythicalTesting:          ***PASSED***
  Overall mythicalReadiness:***PASSED***
-----End of diagnostics-----
The error i was receiving was during the kind of gui set up, when i ran
mythicalLibrarian --mythicalDiagnostics
everything passed normally. Thanks.
Great. Let me know if there are any problems.
I seem to have a little bug... Most of the shows are moving fine, however, I hit a filename being generated with an invalid character (on UNIX anyway) '/'...

"2020 S2011E429 (A Special Edition of 20/20: A Modern Fairytale Recorded [email][email protected]).mpg[/email]"

I fixed it locally, though there's probably a better way...

At line 2749 I added ShowFileName=${ShowFileName//["/"]/}



#check to see if output folder exists
test -d "$MoveDir" && echo "TARGET SET:$MoveDir/$ShowFileName.$OriginalExt"||echo "ERROR: COULD NOT CREATE FOLDER:$MoveDir/$ShowFileName"
As a small feature request, would it be possible to add changing permissions as an option?
You can change the permissions using the user jobs. http://wiki.xbmc.org/index.php?title=Myt...n_UserJobs

I'm trying to figure out how that problem could have happened. A few lines before, the "/" character is deleted

EpisodeSubtitle=`echo $EpisodeSubtitle| tr -d '!|\?*<":>+[]/'"'"`
NewShowName=`echo $NewShowName|tr -d '!|\?*<":>+[]/'"'"`
ShowName=`echo $ShowName|tr -d '!|\?*<":>+[]/'"'"`

What version/ revision number are you running?
can you post the output.log from when the problem occured?