•   
  • 1
  • 143
  • 144
  • 145(current)
  • 146
  • 147
  • 162
  •   
XBMC Constellation For iPad/iPhone by FSS.cc (unofficial remote)
Jete, sorry I didn't respond sooner, however I don't have any PVR builds available to test with so I'm not sure how to actually provide help for this. The only thing I can suggest off the top of my head is did you go into the Apple Settings App and find Constellation in your list, I know there's some settings there for PVR stuff that may or may not help. I don't have any of my devices near me right now to check on them.

A note to everyone: As most of you know I have been dealing with a lot of medical problems the last few years (mainly due to the cancer and spinal injuries) and sadly my main HTPC (HTPC1 from my sig) decided to die last night shortly after I returned home from the hospital so I may not be around for a few days/weeks while I try to figure out how to fix the system; since disability doesn't pay for crap I have no means of buying any new hardware anytime soon; and I also have to prepare for an upcoming surgery near the end of the month. I'm hopefully going to write up something a little later on my personal blog if people are interested in more details but it essentially boils down to if I can't get any incoming funds, I may be leaving the community for awhile since I can't afford to replace everything and it's useless/pointless to continue helping others if all I can do is guess with the advice I give as opposed to checking things first like I've always tried to do in the past. I talked with another user earlier before I started writing this post and they recommended I put up a donation link since I do provide more than just Constellation help for XBMC, like running multiple wiki's, forums, etc. dedicated to HTPC's however I didn't really want to post that here, so if any users do feel the kindness and would like to help, you can PM me and I'll provide a PayPal email address you can donate to. (If users are kind enough to donate ALL the money they send will go directly to fixing/replacing my main HTPC and any left over will go towards my medical and I'll try to come up with a way to acknowledge those users or send them some form of personalized thank you).

Anyway, this isn't a complete farewell (I hope) but I do want to thank Dawid, Burb, and the others that I have worked with providing Constellation support, Martijn, Deja, and the rest that I have worked with in the past on the old XBMC Blackmarket, Maraschino, and other projects I've tried to help out with as well.

Thanks for your time and actually reading this.
AJ (Archigos)

==Edit==
Donation Link can be found on the "My Personal Blog" link in my signature under "HTPC Community" Post.
Direct Link Here
HTPC 1: 64-bit Quad Core 3.4GHz Athlon X4 / 16GB DDR3 / (8) 2TB / 42" Vizio / Windows 8.1 (x64) / IIS 8.5
HTPC 2: 64-bit Quad Core 2.0GHz / 8GB DDR3 / 1TB / Windows 8.1 (x64) / IIS 8.5
My Personal Blog - NewsDemon | Text size doesn't seem to be working anymore for signatures?
Reply
Sorry to hear about your misfortune bro, you can count on a donation from me as this app and the support provided is exceptional Big Grin
Reply
Sorry to hear about your health issues...that sucks Sad

I tried playing around with the options, but to no avail. It's not a major issue. I came from Android using the official remote and there are no PVR functions in there at all, so any PVR functions in this app are a bonus.

I'm sure the devs will provide a fix if the demand is there for it.
Reply
I am using latest frodo xbmc on windows 7.

Its working well except fast forward/rewing button, im not sure what its doing its like it fastforwards/rewinds once quickly then stops?

Also volume when i try to adjust it bitstreaming during a movie, a popup appears typically when using xbmc official app, or an mce remote, or keyboard that passthrough mode is activated, so you cant adjust volume. Constellation is not displaying this message, so other users in my house are asking why you cant control volume. Would be nice if constellation volume worked the same way so the notice pops up like every other controller device. Its almost like constellation is using different commands regarding volume and fast forward and rewind then the official app.


And hope you get better and get enough donations, love this app! Hope to see it continue to improve.
Reply
(2012-12-08, 14:22)Archigos Wrote: What do you mean by the Standard Keys aren't working for you? Are you having an issue adding a button to a specific key, is it doing a different command than you expect or something else? One thing to keep in mind, when you create custom buttons, there's an On/Off toggle in the upper right corner that some people thing means to activate the button or not, however if you read directly above it, it says "Safe button". If you have Safe Button turned on, by default you have to HOLD the button you want until it fills up with color before it activates, which is the desired result and helps you from accidentally hitting buttons you don't mean. So the first thing you want to try is to hold down the button and see if it starts filling with color, if it activates after about a second you know the button is working. If you want to remove the safety feature to buttons you've already created, open the dialog box where you create them and you'll see a list, touch the one you don't want the safety on and you can change the toggle back to off. If I'm way off on the issue you're having, you'll have to repost with more details so I have a better idea what you're talking about.

So Standart key (builtin like "T", "I" and custom that i added in keyboard.xml) doesn`t work for me. While "Special key" and "Builtin Function" works fine.
I have Event server turned on. And HTTP and JSON RPC connected.

In another iOS app "XBMC *****nder" (I don`t want it to be the advertisement) "Standard keys" works perfect.

So hope for your help I really want to delete "XBMC *****nder" but I can`t without this functionality.

ver. 2.8.6
Mac OS and aTV2
iPad 3 and iPhone 4 6.0
Reply
since I bought 'pro' to iphone, the app keep crashing everytime I play a Movie (and Movie only) and exit the app, then Iphone restarts and enter to safe mode.
Reinstall the App does not help.
Win 7\8, FRODO RC3
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
(2013-01-14, 12:24)Ghostdivision Wrote: I am using latest frodo xbmc on windows 7.

Its working well except fast forward/rewing button, im not sure what its doing its like it fastforwards/rewinds once quickly then stops?

Also volume when i try to adjust it bitstreaming during a movie, a popup appears typically when using xbmc official app, or an mce remote, or keyboard that passthrough mode is activated, so you cant adjust volume. Constellation is not displaying this message, so other users in my house are asking why you cant control volume. Would be nice if constellation volume worked the same way so the notice pops up like every other controller device. Its almost like constellation is using different commands regarding volume and fast forward and rewind then the official app.


And hope you get better and get enough donations, love this app! Hope to see it continue to improve.

It would also be nice if you could shut down the system or wake on lan like the official xbmc remote, thats about the only thing I am missing, i currently have to use constellation with the xbmc app due to this.


Reply
It has WOL Suspend and Shutdown functions. In top left corner.
Works perfect in Mac OS
Reply
Deano316, Jete246, everyone else...
Thanks for the well wishes... Thankfully my health has been pretty stable for awhile now, it's just the pain and physically exhausting most of the time... plus disability doesn't pay for crap.

Just a reminder for those that don't know, too lazy to read the blog post, or just forgot... Although I provide a high percent of the tech support for Constellation (among other things) I have never officially worked for FSS (the team behind Constellation) and everything I have done has been 'pro bono' because I like their apps so much. I'm just pointing this out again because of the rude PM I got telling me "You should just take some of the profits you get from Apple selling your app and quit trying to sucker other users into paying for your misfortune" (paraphrased cause I can't stand to copy/paste that many typos Smile ) and wanted to let people know I have NEVER gotten any money from the sale of Constellation or for the support I provide.

For people still interested in reading the blog or donating, the actual post is located here or if you just want to know a little more about me, you can check my About Me page. (I should probably get around to updating that sometime.)

Back to the tech support
@Ghostdivision:
For fast forward/rewind... I haven't seen that happen to anyone else yet. Are you using Constellation on an iPhone or iPad when this happens?
For the volume, I'm not sure what's going on there, if you could PM me some more details I can try to figure something out. The Passthrough notice isn't based on any of the remotes, it's referencing your audio settings inside XBMC itself, so I'm not sure why it wouldn't come up only when using Constellation (as far as I know, Constellation uses the standard "VolumeUp/VolumeDown" like the others).

Are you running your audio directly through your TV or do you have it going to some form of AV Receiver or Surround Sound setup?

Also, as NewFolk pointed out in their post, there is WOL, Shutdown, etc. already in the menu system. From either the iPhone or iPad, touch the "Wifi" icon in the upper left hand corner and you'll notice the buttons you wanted listed in the "Power" section. To get these to work, you have to make sure you have the proper Mac Address listed in your current host. If you don't (or are unsure), touch the little "right arrow" next to your Host (same menu area, at the top), then touch the little "Cog" to edit your host. You'll see a spot for "WOL MAC" and put in your systems Mac Address.

@NewFolk:
There may be a chance that Constellation is looking for a 'keymap.xml' instead of 'keyboard.xml' since I know all the keys I defined in keymap.xml worked fine. I don't remember if I ever tried any of the 'normal' standard keys, like "I", but I set up some customs like "w" to toggle Watched Status and "Ctrl+H" to switch back and forth between "Show All" and "Hide Watched" and they worked great with the buttons I created.
Can you temporarily try to rename 'keyboard.xml' to 'keymap.xml' and see if it works? (This "shouldn't" break the other remotes, but just rename it back if it does after testing.)

From what I understand reading the official Wiki (months ago) is that XBMC itself essentially just grabs ALL *.xml files from the keymap folder and tries to parse them, however in that same article they would reference it as 'keymap.xml' for their examples and I think Constellation may be looking for that specific name. Granted this was incorporated back in the later Dharma days at which point may have required that name and have opened it up to the 'pull all xml files' after that, so Constellation is still just looking for that name. So, best case scenario, renaming your file as I suggested above will hopefully fix this in Constellation and not break any of the other remotes you use so that everything works... if not, instead of renaming it, make a copy so you have both identical files, one with each name, XBMC will parse the first one and ignore the second one since it's the same.

@tomer953:
Are you by chance on a jailbroken device? Your device going into Safe Mode suggests something wrong in the Mobile Substrate which Constellation does NOT affect in any way. What I'd suggest (jailbroken or not) is open the app, give it time to complete it's full sync, do NOT start a movie yet, scroll down to "Settings" and then do "Remove database", confirm that... give it a minute and then do "Resync local data"... again, give it enough time to do a full sync. Force Quit the app, and relaunch... hopefully you'll be fine at that point. They may be something corrupt in your current database causing the app to crash... not sure why it's forcing Safe Mode though... (if you are Jailbroken, they may be a tweak causing the Mobile Substrate crash).
HTPC 1: 64-bit Quad Core 3.4GHz Athlon X4 / 16GB DDR3 / (8) 2TB / 42" Vizio / Windows 8.1 (x64) / IIS 8.5
HTPC 2: 64-bit Quad Core 2.0GHz / 8GB DDR3 / 1TB / Windows 8.1 (x64) / IIS 8.5
My Personal Blog - NewsDemon | Text size doesn't seem to be working anymore for signatures?
Reply
(2013-01-16, 09:11)Archigos Wrote: @tomer953:
Are you by chance on a jailbroken device? Your device going into Safe Mode suggests something wrong in the Mobile Substrate which Constellation does NOT affect in any way. What I'd suggest (jailbroken or not) is open the app, give it time to complete it's full sync, do NOT start a movie yet, scroll down to "Settings" and then do "Remove database", confirm that... give it a minute and then do "Resync local data"... again, give it enough time to do a full sync. Force Quit the app, and relaunch... hopefully you'll be fine at that point. They may be something corrupt in your current database causing the app to crash... not sure why it's forcing Safe Mode though... (if you are Jailbroken, they may be a tweak causing the Mobile Substrate crash).

yes, JB iphone, 5.1.1.
Remove,and resync, and nothing.. still crash and safe mode.. any idea how to grab a log file or something to know whats wrong?
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
(2013-01-16, 09:11)Archigos Wrote: Deano316, Jete246, everyone else...
Thanks for the well wishes... Thankfully my health has been pretty stable for awhile now, it's just the pain and physically exhausting most of the time... plus disability doesn't pay for crap.

Just a reminder for those that don't know, too lazy to read the blog post, or just forgot... Although I provide a high percent of the tech support for Constellation (among other things) I have never officially worked for FSS (the team behind Constellation) and everything I have done has been 'pro bono' because I like their apps so much. I'm just pointing this out again because of the rude PM I got telling me "You should just take some of the profits you get from Apple selling your app and quit trying to sucker other users into paying for your misfortune" (paraphrased cause I can't stand to copy/paste that many typos Smile ) and wanted to let people know I have NEVER gotten any money from the sale of Constellation or for the support I provide.

For people still interested in reading the blog or donating, the actual post is located here or if you just want to know a little more about me, you can check my About Me page. (I should probably get around to updating that sometime.)

That's just crazy I can't believe people would say crap like that!

Quote:Back to the tech support


@tomer953:
Are you by chance on a jailbroken device? Your device going into Safe Mode suggests something wrong in the Mobile Substrate which Constellation does NOT affect in any way. What I'd suggest (jailbroken or not) is open the app, give it time to complete it's full sync, do NOT start a movie yet, scroll down to "Settings" and then do "Remove database", confirm that... give it a minute and then do "Resync local data"... again, give it enough time to do a full sync. Force Quit the app, and relaunch... hopefully you'll be fine at that point. They may be something corrupt in your current database causing the app to crash... not sure why it's forcing Safe Mode though... (if you are Jailbroken, they may be a tweak causing the Mobile Substrate crash).

This has been happening on jailbroken and stock iOS devices, (except the safe mode bit!) I'm sure FSS know about it as its been a long standing issue with the last few constellation betas at least... No news on a fix though to my knowledge
The specific forum for Constellation can be found Here.

If anyone is looking for a usenet account try here, great unlimited service!
Reply
Had a bit of a search but cant find anything on this. I'm using Frodo RC3 and the latest version of Constellation. I test added 5 movies to check everything was setup ok.

Image

Looks good.

Image

What the....? Fair enough those movies do belong to a collection, but I don't have Blair Witch or Cube 2 in the library and when I tap on the 'collection' poster there is nothing inside.

Image Image

A bug? Something I've done?
Reply
@philzy

I guess you could call it a bug, but not a Constellation Bug... the problem here is the new way Frodo handles movie sets (when using TheMovieDB scraper). If I remember right, remove the movies (Cube and the other one) from XBMC, dig around in the settings and turn off the option for automatically creating movie sets, re-scan the two movies... Now, if that doesn't fix it in Constellation right away, you may have to remove the local database in Constellation and resync.


Side Note: From the limited testing I can do right now, it seems, that 'most' of my hard drives survived (lost the one with all my software on it and maybe my TV Mini Series) but the power supply, at minimum half the RAM and the CPU all took a crap. Sad So I'm still working on it guys...
HTPC 1: 64-bit Quad Core 3.4GHz Athlon X4 / 16GB DDR3 / (8) 2TB / 42" Vizio / Windows 8.1 (x64) / IIS 8.5
HTPC 2: 64-bit Quad Core 2.0GHz / 8GB DDR3 / 1TB / Windows 8.1 (x64) / IIS 8.5
My Personal Blog - NewsDemon | Text size doesn't seem to be working anymore for signatures?
Reply
(2013-01-17, 19:50)Archigos Wrote: @philzy

I guess you could call it a bug, but not a Constellation Bug... the problem here is the new way Frodo handles movie sets (when using TheMovieDB scraper). If I remember right, remove the movies (Cube and the other one) from XBMC, dig around in the settings and turn off the option for automatically creating movie sets, re-scan the two movies... Now, if that doesn't fix it in Constellation right away, you may have to remove the local database in Constellation and resync.

I'm using Aeon Nox, so I go to Settings > Video > Group movies in sets (which is already off) switched it on and off again for good measure.

Removed the 2 movies and updated library to readd, wiped and resynced constellation. Still no change.

<set>The Blair Witch Collection</set>
Exported the database and found this so obviously XBMC is saying its a collection even though the tickbox is set to off. Removed this line and imported the database back in and all is well, its ok to do this wit 5 moies but I have nearly 800 on my HTPC hard drives
Reply
(2013-01-17, 19:58)philzy Wrote: <set>The Blair Witch Collection</set>
Exported the database and found this so obviously XBMC is saying its a collection even though the tickbox is set to off. Removed this line and imported the database back in and all is well, its ok to do this wit 5 moies but I have nearly 800 on my HTPC hard drives

Does each movie have a metadata file with the movie itself? and do you use them for anything else other than movie set grouping? An easy fix is delete the metadata, the time consuming fix is edit each one! not great news i suppose but i have no metadata files in my library and the only issue at the moment is the sorting of some recently added movies, but thats another Frodo change that happened since the last constellation release.
The specific forum for Constellation can be found Here.

If anyone is looking for a usenet account try here, great unlimited service!
Reply
  •   
  • 1
  • 143
  • 144
  • 145(current)
  • 146
  • 147
  • 162
  •   



Logout Mark Read Team Forum Stats Members Help
XBMC Constellation For iPad/iPhone by FSS.cc (unofficial remote)5
This forum uses Lukasz Tkacz MyBB addons.