17.4 scan to library problem
#1
I've installed 17.4 today and 2 hours laters i've revert back to 17.3.
Situation:, can't tell if it was worse then only this setting.

Need to sketch my kodi system 1st to explain some things, which i think none will bother but they just might.
I've 2 active profiles: main kodi user and Nederlands.
Nederlands i use to scan dutch spoken movies into my system with the correct poster (or i make them so etc).
I've english spoken movies, dutch spoken movies and dutch&english spoken movies. The last movie type has it's own folder called
dualfilms and a junction towards this directory as dualfilms junction.
This way with multi-foldering i've a overview with all english spoken movies and can play them directly english spoken.
Switching to Netherlands, allows me to just see a list of dutch spoken movies and allows me to play them directly.


This all above just works fines, where is the problem for me found in 17.4.

I was adding dutch movies to my library (from the nederlands profile) and when i activated scan to library through the context menu (i use transparency skin) just nothing happens, if i on the other hand activate scan for new contents i could if the title was recognized directly it was added. So the adding mechanism seems to work, but not the activation of the manual addition somehow.

I use tmdb and the universal movie scraper, the 1st mostly for more rare dutch movies, the last mostly for anything english.
After i stepped back to 17.3 everything worked fine again.

Anyone able to tell me how to solve this problem? Or what the reason is it fails?
Reply
#2
The behaviour or how to bring the manual scraper into view has changed somewhat from what I can see. In the case of an incorrect scrape, the information screen of the mistake brings the option for a refresh, and in that function, a denial, and subsequent 'No' for locally stored and refresh from the internet will bring the 'select show' and manual option on Transparency!
Reply
#3
(2017-08-28, 19:56)PatK Wrote: The behaviour or how to bring the manual scraper into view has changed somewhat from what I can see. In the case of an incorrect scrape, the information screen of the mistake brings the option for a refresh, and in that function, a denial, and subsequent 'No' for locally stored and refresh from the internet will bring the 'select show' and manual option on Transparency!

In case of scan to library u normally would get a choice list so u could pick the correct one. Here u would be able to go manual or if it couldn't find a hit it would go directly to the manual find box. But in above situation under 17.4. No scan at all is accomplish when i pushed scan to library. And with the scan for new contents option u never get a chance to go manual. For most english movies this is not that much of a problem, allthough for dutch movies i've to seek up half of the contents by hand to actually get the correct hit.

And a refresh in my skin at least only shows up after u've entered the movie into your library. Where the problem lays is, in getting them into my library.
Reply
#4
Using the default skin Estuary, I can confirm this issue on v17.4 on Win10

If I add a single new movie to my source, then navigate to Videos>Files>MySource. Locate the new, unscraped movie. Previously, I could...

1. press the "I" (information) key and it would scrape that individual movie.
2. select the "Scan to library" option in the context menu, which would also scrape the single movie.

Both these options are no longer working.

I still have v17.3 on my main Kodi install, and both those methods work.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#5
Can't confirm this behavior Krypton 17.4 , just pulled in meta-data with 'scan for new content' for both movies and TV episodes. Leia Alpha seems to work in the same fashion for movies and TV listings. The context Information menu only seems to be available when there is meta-data information. Once scraped, information menu item is active in context, at which time a rescan is possible, with a denial of 'Locally stored information found, ignore and refresh from the internet' produces a scraper query with the manual option (almost the reverse of the meaning IMHO).

http://imgur.com/a/hkLNF

Scan to library doesn't seem to function.
Reply
#6
Hi PatK

No, not Scan for new Content. That is like Update Library.

Try Scan to library, or press for Movie Information in the Videos>Files section

Upto v17.3, calling Information started the scrape for the individual movie. Can replicate this step no problems on my machine.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#7
Kodi 17.4 on Ubuntu 16.04.3 LTS, scanning works just fine for movies as well as series.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#8
Got that then the function is broken in windows if other platforms behave as per 16, 17.3
Reply
#9
Also identical behavior in Mac; 17.3 worked, 17.4 lost the information on both windows and Mac for me.

My video source is a SAMBA folder if that makes a difference.
Kodi: Kodi 17.4, with Transparency!
50 TB Unraid Server: Docker Apps: SABnzbd, Sickrage, mariaDB
HTPC: Win10 (cause Steam), i7, GTX 1080
Watching on: Panasonic TC65-PS64 with lowend Sony 5.1 HTIB
Other devices: rMBP 15", MBA 13", nvidia shield
Reply
#10
I can confirm the using "I" function is working OK in Leia builds, see here
I'm a XBMC novice :)
Reply
#11
(2017-08-30, 09:02)skylarking Wrote: I can confirm the using "I" function is working OK in Leia builds, see here
Yes both Krypton 17.4 and Leia information functions work at file level from the keyboard 'i' short-cut, but not folder level as what has been known previously.
Reply
#12
Confirmed that bug also exists in the 17.4rc1, so it was introduced somewhere in here

EDIT -> Tried a nightly from the 2017-07-25, and the information button worked on folders there... That narrows it down to this small window.
Kodi: Kodi 17.4, with Transparency!
50 TB Unraid Server: Docker Apps: SABnzbd, Sickrage, mariaDB
HTPC: Win10 (cause Steam), i7, GTX 1080
Watching on: Panasonic TC65-PS64 with lowend Sony 5.1 HTIB
Other devices: rMBP 15", MBA 13", nvidia shield
Reply
#13
Kodi v18 "Leia" KodiSetup-20170831-e22038f8ee-master-x64 2017-Sep-01 03:56
windows 7 x64
Scan to library doesn't work
Reply
#14
Can just confirm that I have the same issues.

Just did a fresh install of Krypton 17.4 on my new NUC and I'm used to having to manually add some movies and tv-shows in my library. Right now that seems to be impossible.

On older versions you could select the Information-option from the C-menu but I guess that has been replaced by "Scan to library", selecting this does nothing however.
Reply
#15
Up until v17.3 you could use either the "I" button on the remote, or use the "Scan to Library"

You can still add movies to the library by using the Update Library option. This scans all sources for new content, rather than a single movie. Depending upon the size of your library, it should only take a few seconds longer. Access this option from the side panel settings in the Movie section of the main menu. If you are not sure how, see here... http://kodi.wiki/view/Basic_controls#Sidebar_menu


Related threads
320666 (thread)
320871 (thread)
320387 (thread)
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
17.4 scan to library problem51