Kodi Community Forum

Full Version: [RELEASE] MythBox for XBMC - a MythTV Front-end Python Script for XBMC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I now get a all TV tuners in use error when I try to watch tv. Bugger

EDIT: Got passed that problem. Now I have an issue with changing channels. If i use the numbers on the remote then the whole of xbmc crashes and locks up

I've installed the plugin on xbmc running on a macbook. I can go into it, but there is half an error message showing, that I can't read. I think its saying I have a permission problem connecting to the mysql on the mythbackend.

My problem is that I can't find the log files. I've looked in ~/Library/Logs and there isn't a mythbox.log file there. Also, there is no corresponding error in xbmc.log.

Any suggestions ? Should I try to remove and re-install ?

Hey guys, now that XBMC has been ported to Android what is the possibility of this MythBox addon working with it?

Mythbox has ridded most of its windows dependencies I believe at this point my best suggestion would be to test it with both mounted shares and with streaming and see if either works.
Alright, I thought I could figure this out on my own, but I am lost.
Goal: Run mythbox on same PC as backend (mythbuntu installed)

Heres what I have done so far:
1. installed mythbuntu
2. set ip address on backend and frontend to local ip address (
3. Set Bind-address (my.cnf) to local IP address -
4. Install XBMC and mythbox
5. Mythbox - set IP to, type in password from mythtv frontend (is this right?)

Results in Connection Failed

What else can I try? Everything is new to me including Linux/Mythbuntu. Please be as basic as possible
The mythbox settings are for connecting to the mysql server. The credentials used on the settings page you should be able to use from the mysql client so for example:
mysql -h -p myththv -u mythtv mythconverg --P 3306

if the mysql command fails figure that out and then xbmc should work.
Are you using myth 0.25? It updated the protocol for communicating with this plugin. You'll need updated versions of xbmc and the mythbox plugin from their github repo.
That fixed it for me. I'd setup all the host database stuff correctly, but in the logs I could see lines about unsupported protocol version. So, I updated to the github version and it worked again Smile

If you update and still cant sort it, maybe post your xbmc log so we can have a look.
kind of off topic here.. but i figured i'd ask.. i cant for the life of me find a fool proof way to install mythtv for windows (the server). can anyone give me a great guide to do so?
(2012-07-24, 17:32)jeffbaier Wrote: [ -> ]Are you using myth 0.25? It updated the protocol for communicating with this plugin. You'll need updated versions of xbmc and the mythbox plugin from their github repo.

I feel like I'm out of my league, I find one thing out, but then have thousands of more questions.
Ok, I'm serious when I say I'm a Linux noob, y'all ready to laugh...

As for updating XBMC to a nightly (currently on 11.0 stable), Do I get the Zip from this page and follow the readme:
If so, what does this mean "You will have to grab the source code of course. First install the git package provided by your distribution."
Updated my mythbox on github .. i get list of recordings and list of channels but nothing happens when i click them.

Have upodated the plugin from the git repo, and it can connect/see channels/recordings.

However if I try to watch live TV I still see the error re version wrong:

Aug 12 11:37:02 sidekick mythbackend[8585]: C ProcessRequest mainserver.cpp:1259 (HandleVersion) MainServer::HandleVersion - Client speaks protocol version 8 but we speak 72!
Aug 12 11:37:02 sidekick mythbackend[8585]: W ProcessRequest mainserver.cpp:5801 (connectionClosed) MainServer: Unknown socket closing MythSocket(0x1f148d0)
Aug 12 11:37:02 sidekick mythbackend[8585]: W Socket mainserver.cpp:5801 (connectionClosed) MainServer: Unknown socket closing MythSocket(0x1ee99d0)

Any suggestions?
an0key read the thread.
Ok maybe someone else is having the same frustrations as I am. I am trying to get MythTV to work in XBMC.....my starting point you might askHuh Never used MythTV before and never set it up. I have read way too much information and don't know where to start.

I have AMD based PC running windows 7 and have a Hauppauge WinTV-HVR 950Q Hybrid TV-Stick.

I have tried to download mythtv for windows but was getting a missing DLL file error after trying to execute the program after what I thought was a successful install. I donwloaded the missing dll file and put it in the bin folder...then mythtv didn't give me the missing dll file error but still failed to start.

My understanding is that I have to get MythTV running on the frontend before I can use mythtv as a backend through XBMC.

Am I on the right track? Can anyone help me out?
I installed this today but when I try to launch it I get "Connect to mySQL failed: 2003: can't connect to mySQL" as an error message. I've searched but can't figure out how to fix it. Any help would be very appreciated. Would love to have it up and running so I could record the space walk on Monday. I'm using a Mac OSX with the 10.6.8 version. I'm very new to all of this stuff and my wireless network is password protected if that factors into this issue. Thanks!