Kodi Community Forum

Full Version: [RELEASE] veetle.com
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
Not working for me either...

(10.1 on gen1 Apple TV using 0.1.6)
[not working on my xbox either]
Not working on ubuntu 11
not working on windows
running appletv2nd gen latest everything and veetle from tommos 1.0.3 repo tried reinstalling after uninstalling veetle and the repository nothing seems to work keep getting playback errors I love this addon the most and appreciate the work done here
last time this happened eldorado upgraded from 101 to 103 in tommos repo
its not the plugin, something has changed on veetle's end. would crossdomain apply?.. i used to be able to open the streams in smplayer or vlc, but thats not working also, and tried jtv player, the flash streams just dont stream externally anymore.
re: vlc - good idea... I tried it, and WAS able to do a stream. Sequence:

in IE, open http://www.veetle.com/channel-listing-cross-site.js and save the file

open it in notepad, get the 'channelId' for a flash stream, construct following url
[http://veetle.com/index.php/channel/ajax...ELID/flash]

enter it in IE, grab displayed 'payload' string, remove backslashes, paste url into vlc

Does 'xbmcplugin.setResolvedUrl' obey/remove the backslash quoting?
What Useragent do xbmc and vlc use in the http header?

edit: er, uh, well, vlc will play some of the streams. for example
"africanmoviechannel's channel" channelid 4df60ee1294bc yields
[http://216.221.144.244/flv/4df60ee1294bc] which vlc will play
here is a log of it failing in xbmc:

Code:
17:04:39 T:2604  NOTICE: veetle Category ID: 10
17:04:40 T:2604  NOTICE: Total veetle.com Channels: 210
17:04:40 T:2604  NOTICE: Flash Enabled veetle.com Channels: 105
17:04:47 T:2856  NOTICE: -->Python Interpreter Initialized<--
17:04:47 T:2856  NOTICE: veetle.com Channel ID: 502f8ced9f4ad
17:04:48 T:2856  NOTICE: getting: http://www.veetle.com/index.php/channel/ajaxStreamLocation/502f8ced9f4ad/flash
17:04:48 T:2856  NOTICE: {u'statsServiceEnabled': False, u'payload': u'http://216.221.144.235/flv/502f8ced9f4ad', u'success': True, u'statsServerURL': u''}
17:04:48 T:2880  NOTICE: DVDPlayer: Opening: http://216.221.144.235/flv/502f8ced9f4ad
17:04:48 T:2880 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
17:04:49 T:1452  NOTICE: Creating InputStream
17:04:49 T:1452  NOTICE: Creating Demuxer
17:04:55 T:1452   ERROR: CDVDDemuxFFmpeg::Open - error probing input format, http://216.221.144.235/flv/502f8ced9f4ad
17:04:55 T:1452   ERROR: CDVDPlayer::OpenDemuxStream - Error creating demuxer
17:04:55 T:1452  NOTICE: CDVDPlayer::OnExit()
17:04:55 T:1452  NOTICE: CDVDPlayer::OnExit() deleting input stream
17:04:55 T:2880   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.veetle/?play=502f8ced9f4ad]
17:04:55 T:2880  NOTICE: CDVDPlayer::CloseFile()
17:04:55 T:2880 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
17:04:55 T:2880  NOTICE: DVDPlayer: waiting for threads to exit
17:04:55 T:2880  NOTICE: DVDPlayer: finished waiting
17:05:18 T:2848  NOTICE: -->Python Interpreter Initialized<--
17:05:19 T:2420 WARNING: XFILE::CFactoryDirectory::Create - Unsupported protocol(script) in script://
17:08:42 T:696 WARNING: Previous line repeats 1 times.
17:08:42 T:696  NOTICE: -->Python Interpreter Initialized<--
17:08:43 T:2780  NOTICE: -->Python Interpreter Initialized<--
Yeah, that seems consistent with the vlc verbose logging.
It starts scanning the streams and can't figure them out...

FYI - The 'africanmoviechannel channel' still plays in xbmc.

bummer...
could the format have changed?


snippet on the start of the stream:
Code:
GGG Ý onMetaData duration [email protected] [email protected]`[email protected]çpaudiosamplesizestereo [email protected]

the one that works (african)
Code:
FLV Ý onMetaData duration [email protected] [email protected]@[email protected]刀audiosamplesizestereo [email protected]

GGG?
Hmmm... well spotted! I was looking further on and missed that...

Assuming vlc & xbmc have code that is looking for that leading 'FLV' (and the string constant can be found via hex editor), then a simple binary patch to change it to 'GGG' would tell us a lot...

I was also wondering about http headers (mime types, ua, etc) but don't have a wireshark setup handy to cap them...
sigh...

Hacked a copy of vlc, changing all 'flv' to 'ggg' in libvlccore.dll and libavcodec_plugin.dll. Still recognizes 'african' (and all the verbose logging now says 'ggg') but still doesn't play other veetle streams. So either I missed a dll (fair chance, 250+ in the plugins dir) or vlc is using some other heuristic to detect flash streams...

I may try a similar hack on xbmc4xbox binaries tomorrow...

thats what it is, the GGG is messing it up. downloaded a partial stream, changed the GGG to FLV using a hex editor and it opened up fine.. the format isn't being recognized, thats why its throwing errors. now how to fix this issue? i don't know much about xbmc's workings. hope someone has a clue.
plz fix the veetle addon as no video is playing.
+1 it seems to be broken the last few days. Ie the videostreams show up but they do not play.
Gull, tuxen, etc - it is NOT the add-on; veetle have changed the actual stream data...

netimports - did you play the cap'd & hak'd stream with vlc or xbmc? As a .flv file??

-----

Assuming the FLV->GGG prefix is really all they did, I got to wondering, how THEY are handling this.

Inspection of a channel web page html (very bottom of the file) reveals /minified/HEXSTRING_minified.js. Nearly impossible to read, but nonetheless I found http://veetle.com/flash/playerComputer_20120824.swf
Interesting filename - Aug 24 2012 - just before the stream format change...
Snagged a copy of the file, but didn't find 'ggg' embedded in it. Any swf hackers out there??

Another interesting thing in the minified.js - looks like there is some html5 support in there.
Perhaps we can sidestep flash entirely? Would mean a completely new addon?? (ugh)

PS - the african channel is now behaving the same as the others (ie 'GGG' prefix)
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31