Kodi Community Forum

Full Version: [WIP] HTPC-Manager Beta, Manage XBMC, Sabnzbd, SickBeard with one app
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2012-08-08, 17:10)Aenima99x Wrote: [ -> ]Yes, using the latest commit. The Recently Added Music disappeared for me.
Recently added music should be working again.

(2012-08-13, 20:29)tylertech Wrote: [ -> ]
(2012-07-28, 23:41)Hjord Wrote: [ -> ]Looks awesome.
Any chance for adding Headphones to it?

I 2nd this. Seems like Headphones would be a nice addition and one many people would like to see.
Big Grin

I have plenty of work extending the current functionality and with the Squeezebox functionality atm. Since I don't use headphones I wont be adding it any time soon.

But i have done a lot of work trying to make the interface as easy as possible to extend. So if anyone feels like writing a Headphones module I would be more than happy to add it to my repo.
(2012-08-07, 19:39)mbw2001 Wrote: [ -> ]Latest commit now has support for setting datadir, pid and port through commandline parameters.

Thanks! This'll make a lot of users over on the unraid forums happy, they've been anxiously awaiting the htpc_manager plugin for their servers, with these settings it will be easier to implement. I'll get right on that, Big Grin

EDIT: Not sure if you'll be able to help me, but when starting the app from the command line directly, it works fine. If I try to start the app passing the command from the plug-in, it starts, but Cherrypy throws an error:

Traceback (most recent call last):
  File "/usr/local/htpcmanager/libs/cherrypy/_cprequest.py", line 656, in respond
    response.body = self.handler()
  File "/usr/local/htpcmanager/libs/cherrypy/lib/encoding.py", line 188, in __call__
    self.body = self.oldhandler(*args, **kwargs)
  File "/usr/local/htpcmanager/libs/cherrypy/_cpdispatch.py", line 34, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/usr/local/htpcmanager/htpc/index.py", line 7, in index
    return template('dash.html')
  File "/usr/local/htpcmanager/htpc/tools.py", line 7, in template
    return lookup.get_template(template).render()
  File "/usr/local/htpcmanager/libs/mako/lookup.py", line 243, in get_template
    "Cant locate template for uri %r" % uri)
TopLevelLookupException: Cant locate template for uri 'dash.html'

EDIT 2: Ok, if the command is called from another directory it won't work, I had to cd into the install directory and then give the start command ( sudo -u nobody python /usr/local/htpcmanager/Htpc.py --daemon ) for it to work...is this a limitation of Mako or a possible bug?
Anyone got it running on Linux? It won't launch here using ./Htpc.py --deamon. Well it launches but can't connect to it.

Trying to make package as requested here https://github.com/SynoCommunity/spksrc/issues/222
Try starting with "python Htpc.py --debug" and see post the result.
(2012-08-31, 12:27)mbw2001 Wrote: [ -> ]Try starting with "python Htpc.py --debug" and see post the result.

Thanks and almost got the package ready except for 1 minor detail and that is pid argument. When i use --pid i'm getting the following error:

08:32:18 (master) ~/HTPCManager$ ./Htpc.py --datadir /home/openelec/HTPCManager/userdata/ --debug --pid /home/openelec/HTPCManager/userdata/htpcmanager.pid
Traceback (most recent call last):
  File "./Htpc.py", line 89, in <module>
  File "./Htpc.py", line 86, in main
  File "/home/openelec/HTPCManager/htpc/server.py", line 24, in start
    PIDFile(cherrypy.engine, args.pid).subscribe()
NameError: global name 'args' is not defined

Any ideas?
Yeah... In htpc/server.py change line 24 change args.pid into htpc.pid

I'll fix it in the next version, but I',m doing some major changes trying to get closer to pep8 / pyling valid code... and it will take a while....
That is a problem I'm getting as well! I haven't had a chance to look at the source yet. Having a couple issues after the PIL update, checking now to see if the commit after that fixed them or not.

Mbw, mind if I pull your recent commits and then send a pull request with the change from args.pid to htpc.pid? That way you can accept the pull request and it will fix it in the meantime.
Nah that would be very fine....

Any bugfixes / features are very welcome...
Alright, the pull request was sent. I sent the pull request, on github I'm influencer. I don't know python well but learning, this one of course was simple and you gave the answer lol.
ok.. i went ahead and set a password for xbmc because whenever I tried to play a movie in HTPC Manager from XBMC.. it prompted for a password.. it still does not switch the movie in XBMC when I click "play".

Any ideas? any kind of logging?

i am getting the thumbnail error:
PHP Code:
500 Internal Server Error

The server encountered an unexpected condition which prevented it from fulfilling the request

Traceback (most recent call last):
File "/c/HTPC-Manager/libs/cherrypy/_cprequest.py"line 656in respond
.body self.handler()
File "/c/HTPC-Manager/libs/cherrypy/lib/encoding.py"line 188in __call__
.body self.oldhandler(*args, **kwargs)
File "/c/HTPC-Manager/libs/cherrypy/_cpdispatch.py"line 34in __call__
return self.callable(*self.args, **self.kwargs)
File "/c/HTPC-Manager/htpc/pagehandler.py"line 154in json
return xbmc(host,port,username,password,self.root,hidewatched,ignorearticle).sendRequest(kwargs)
File "/c/HTPC-Manager/htpc/xbmc.py"line 29in sendRequest
return self.GetThumb(args.get('thumb'), args.get('w'), args.get('h'), opacity)
File "/c/HTPC-Manager/htpc/xbmc.py"line 88in GetThumb
image.resize((widthheight), Image.ANTIALIAS).convert('RGBA')
File "/c/HTPC-Manager/libs/PIL/Image.py"line 1290in resize
File "/c/HTPC-Manager/libs/PIL/ImageFile.py"line 164in load
File "/c/HTPC-Manager/libs/PIL/ImageFile.py"line 231in load_prepare
.im Image.core.new(self.modeself.size)
File "/c/HTPC-Manager/libs/PIL/Image.py"line 39in __getattr__
    raise ImportError
("The _imaging C module is not installed")
ImportErrorThe _imaging C module is not installed 

I am running this on a readynas ultra, and would appreciate any help getting this working, as i have searched and tried everything i can. Confused
Received an error message this morning during the latest update, and everytime I select the ARTISTS view:


HP seems to be running OK, apart from this message ??
(2012-10-10, 12:30)CBers Wrote: [ -> ]Received an error message this morning during the latest update, and everytime I select the ARTISTS view:


HP seems to be running OK, apart from this message ??
Try to clear browser cache and launch again.
(2012-10-10, 13:31)redglory Wrote: [ -> ]
(2012-10-10, 12:30)CBers Wrote: [ -> ]Received an error message this morning during the latest update, and everytime I select the ARTISTS view:


HP seems to be running OK, apart from this message ??
Try to clear browser cache and launch again.

Thanks REDGLORY, that seems to have fixed it Big Grin
No problem. Had similar problem after headphones update.