Kodi Community Forum

Full Version: XBMC Video Server: stream/download your library contents
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
zaleen Wrote:For the watched status - if we set up other users in user management, can they have their own watched status rather then them changing our db? Or is there any thoughts to doing this in future?

Another user was asking for the same thing actually. While it may be implemented in the future, for now it just mirrors the watched status you see in XBMC itself. One thing that is still missing is to actually mark something as watched when you stream it. The code is pretty much there, I just didn't think about it before now.

zaleen Wrote:2. Mine seems to be working like 80% of the time and then occasionally throws an error 500 'the backend is currently unavailable'. If I wait a few seconds and refresh or go back to the home page it works again. I thought i was fighting for a port number so I changed the port number being used by XBMC Web Server but that didn't help. Currently both the XBMC Host Server and the Apache Web Server hosting the Video Server are my personal desktop (so I used localhost during the setup of the backend) and the DB for XBMC is housed on my QNAP NAS.

Could you try increasing this value to 5 (that's what it was initially)? https://github.com/Jalle19/xbmc-video-se...nd.php#L28. You could also post the relevant log entry to pastebin.com and link it here just in case.

zaleen Wrote:3. That brings me to my 3rd question. I seen some instructions for setting this up on Synology, Would anyone be able to post instructions to set it up on a qnap? I'd love to get it off my personal desktop

Since you actually have a QNAP device I'd say you're the most fit to write a guide. I'm in the process of moving installation instructions to the wiki so it would be great to get instructions for more "exotic devices" in there as well (one guy already wrote a rough manual for Synology, I just haven't been able to test it yet since I can't get the latest version of Synology DSM to work in a virtual machine).

sp8ced21 Wrote:hey negge, can i pick your brain, when i download files they seem to fail 5-10 min in the download and dont sucessfully download the full file, any idea what might be causing this?

I'm not sure about that one, you could try without the reverse proxy and see if it helps. Is this on your Synology?

(2014-07-06, 20:38)Polartch Wrote: [ -> ]I am able to download everything with git via the instructions listed, however when I attempt to access the initial setup via localhost/xbmc-video-server, it sends me to a directory listing the files. In the /var/log/apache2/error.log it shows
Code:
[Sun Jul 06 12:26:38 2014] [error] [client 192.168.2.7] File does not exist: /var/www/xbmc-video-server/src/site, referer: http://192.168.2.99/xbmc-video-server/
which I would assume is the issue. I'm not quite sure where to go from here, any help would be greatly appreciated!

Sounds like you don't have the "rewrite" module enabled in Apache. What operating system are you using and did you follow the instructions exactly?
I followed the listed instructions exactly, and am running RaspBMC, and attempted to install using the Debian instruction set.

When I typed in the
Code:
a2enmod rewrite expires
it responded with
Code:
Module rewrite already enabled
Module expires already enabled
Are you sure you have PHP installed? Did you restart Apache after doing all the installation steps?
Yes, the only thing that came up that was weird during the installation was when installing the listed packages, it responded with a
Code:
Note, selecting 'php5-common' instead of 'php5-json'
, but continued the installation otherwise fine. I followed the listed instructions verbatim, and have been puzzling at this for a few days now.
What files do you see when you browse to /xbmc-video-server? Can you paste your default.conf from the sites-available folder?
Here is the directory that it directs me to when I browse my localhost/xbmc-video-serverImage

Here is the code for the default file
Code:
<VirtualHost *:443>
        ServerAdmin [email protected]

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
        <Directory /var/www/xbmc-video-server/>
                Options FollowSymLinks
                AllowOverride All
                Order allow,deny
                Allow from all
        </Directory>
</VirtualHost>

Thank you, by the way, for all of your assistance so far. I really appreciate it.
The file you posted looks like the "default-ssl.conf" file which is only used if you access the page using https://. Try adding that last <Directory> block to the other file too (the one with "<VirtualHost *:80>" in the beginning) and restart Apache, that should hopefully do the trick.
That worked perfectly! Thank you so much for your help, I am very appreciative.
does anyone know why im getting this on the initial setup?

HTTP Error 404.0 - Not Found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
What URL are you trying to access?
http://localhost/xbmc-video-server
And you have put the project files in c:\xampp\htdocs\xbmc-video-server and followed the rest of the instructions?
I've moved all installation and usage instructions to the wiki on Github, it is no open for everyone with a Github account so if you have something to add, feel free to. Especially the Synology DSM installation instructions needs finishing, I wasn't able to get further than its current state with v4.3 (you need 5.0 unless you want to hack everything).

In other news:

CHANGELOG.md Wrote:#### 1.6.4
* fixed a copy-paste error when logging streamed TV shows
* under-the-hood improvements to the way "not found" pages are generated

#### 1.6.3
* added German translation (thanks to @Victor61)
* added a missing French translation
* increased the backend socket timeout to 5 seconds, this should hopefully fix some "The backend is not connectable" error messages
* added ability to retrieve a playlist for a complete season

Remember to create issues on Github if you find any bugs or have any feature requests!
yes there are files in that folder and yes i did follow the directions
@crxman can you pastebin the Apache error log? There should be a way to open it from the XAMPP control panel.