Kodi Community Forum

Full Version: Windows DirectX 11 upgrade test thread
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2015-02-20, 14:30)afedchin Wrote: [ -> ]@Martijn
Thanks. I need more testing to find reason of issue. Please try next build (Febrary 20) which include rework of dxva renderer and a lot of debug messages.

You don't need to reboot computer. If you wanna not loose all setting, backup your %APPDATA%\Kodi folder or launch Kodi with -p parameter.

Thanks for feedback.

It was not necessary to remove the ad.xml it required to test all rendering paths.

Let's me explain.
By default in the Kodi's settings the render method is Auto and DXVA2 acceleration is enabled. The Auto setting of render method means what will be used pixel shaders for rendering. But if DXVA2 acceleration is enabled and current video is supported by hardware decoder the Kodi forces the rendering method to DXVA and doesn't matter what is setted up in the settings. Using DXVA2 decoding and DXVA rendering is optimal way to display video content.

The flag <forcedxvarenderer>false</forcedxvarenderer> in your advancedsetting.xml disables default behavior and allows using any other rendering method with the dxva2 decoding. But this is not optimal and uses a more CPU/GPU and memory usage.

So to try a new build, when unistalling the old kodi i have to delete profile folder right?
You haven't to uninstall old version. Just install new one. But you have to backup %ADDDATA%\Kodi folder just in case.
Still nothing. Tried hardware/software accelerated. Switched rendere dxva/software but still same result
Have you got any video picture with disabled DXVA2 acceleration and any renderer which is not DXVA?
nope, not on fullscreen video. need to try again to be sure
Is it depends on render method? or with all renderers no picture on fullscreen only?
i have to pick software/pixel shaders and software acceleration to get video in full screen.

having either dxva shader or dxva hardware doesn't give video on fullscreen
Ok so I put the advancesettings back and ran the tests again with the latest build. with hardware + DXVA 2 and auto render it works, with hardware and auto render only it works. With software and DXVA render it does not work, so I am guess the render is the problem??

Oh and thanks for the explanation helped a lot. If you need me to test in any other way feel free to ask.

Log: http://pastebin.com/GwcJ5S22

While I was writing this I tried testing with hardware + DXVA 2 and DXVA render to see what would happen and It didn't work. Here is the log for that run.

Log 2: http://pastebin.com/CxmB3f2Z
@Martijn, @poplap
try this quick fix https://www.dropbox.com/s/0watpc3d91grl84/Kodi.exe?dl=0. just replace Kodi.exe in your folder. If it will not help I really don't know what is reason of issue.
(2015-02-20, 00:00)tfouto Wrote: [ -> ]
(2015-02-17, 03:38)kricker Wrote: [ -> ]
(2015-02-16, 22:49)tfouto Wrote: [ -> ]hi,

Have test it, and the fonts below on RSS become broken if i Alt+Enter (Make window not fullscreen).

Nvidia Gtx 670.
Windows 8.1.
I am seeing the same thing on Nvidia GTX 750Ti with the Feb 16th build. I haven't tested on the Intel GPU yet.

Whenever Kodi is toggled from fullscreen to windows and back again, the RSS feed in fullscreen mode is really messed up. It stays messed up until the text "- Release candidate 3 - Kodi 14.0 Helix....." enters the screen. Then the text looks proper. Once the feed starts over, the first part is all messed up again. Toggling back to windowed mode, the feed always looks correct.


This problem on my NVIDIA gtx 670 still persists on 19 build. Do i have to reboot computer?

Error persists on latest build...
Please do not spam about this issue if i didn't say what it fixed. ok?
(2015-02-20, 23:46)afedchin Wrote: [ -> ]@tfouto
Please do not spam about this issue if i didn't say what it fixed. ok?

ok, sorry. my fault...
Sadly it still is not fixed, with the advancesettings still there it work like it did before, but I still got the black screen with DXVA render selected. Maybe an application is interfering with it?? I will try the lastest build on my windows laptop which has a similar application load but an Nvidia Quadro 1000m, that will at least rule out if its a driver issue. I will try it tomorrow when I have more time for testing.

log: http://pastebin.com/aEKZ3JFf
Ok so I tested it on my laptop and I had no problem even when the render was set to DXVA, Now I have no idea what could be wrong.

i7-2720QM 2.20Ghz
16GB Ram
Nvidia 1000m
I think what it could be AMD drivers issue.