Kodi Community Forum

Full Version: HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
There were, and still may be, certain conditions when stereoscopic is not always ON in the NCP.  In the past (and not sure if still true today - I haven't tested recently) when an HDR title was played, for some odd reason stereoscopic would disable and not reenable.  This meant that a subsequent playback of a 3D title using PDVD would render in 2D until stereoscopic was manually enabled.  I created the .bat to automate this.  The .bat file forces it ON prior to 3D playback or PDVD will simply play in 2D.  madVR has its own mechanism to enable stereoscopic but PDVD does not use madVR.  That said, stereoscopic is ALWAYS ENABLED on my system with no adverse affects playing anything 2D.  Also, the .bat provides an avenue to start other .exe's prior to playback when needed/desired.  Lastly, the .bat utilizes Virtual Clone Drive for mounting iso's which is much quicker than PDVD's internal mounting. 

There is an <exit> tag in the .bat code but it doesn't affect 'exiting' PDVD.  By its nature, exiting returns to the beginning of the PDVD GUI for main movie only titles such as mkv's or to the disc menu when using iso's.  It doesn't quit the program.  To quit, I use alt + F4 as noted in the guide which returns me to KODI library in focus ready for navigation.  It should be noted both PowerDVD v.18 and DVDFab Media Player v.3 both require an alt + F4 key to quit the programs while MPC players 'auto quit' using the feature they provide returning to KODI in focus.
I was curious, as would be interested in any solution that makes that annoying "Press OK when Playback has ended" pop-up "go away" when exiting back to KODI from an external player. At least there would be an option in the settings to turn it ON/OFF as preferred. As far as I know media box special KODI forks as ZDMC and XBMC doesn't have this pop-up in the case of external players.
I don't get that pop-up error.  I think you get it because you are not using an official version of KODI which requires you to disable 'use a fullscreen window'.  When using official KODI, I've only seen that error when fullscreen is turned off.  Mine is always on.  There could be other reasons.
So seeing as I do not have a 3D display and will not get one as my other half can not watch 3D. I should be fine with out the batch file I do not use iso files any more just the .m2ts files from movies I have converted in the past. If one were to add a delay in harmony and add an ok key pass would that work when returning to Kodi?
No, just map alt + F4 and be done with it.  Watch a title with PDVD- press a key on your remote once - return to KODI in focus.  Or, request PDVD to add a quit program function after playback.
(2019-01-07, 17:44)brazen1 Wrote: [ -> ]I don't get that pop-up error.  I think you get it because you are not using an official version of KODI which requires you to disable 'use a fullscreen window'.  When using official KODI, I've only seen that error when fullscreen is turned off.  Mine is always on.  There could be other reasons.
 That's not (intended to be) an "error". By the words of KODI developers it's a "feature", and they've implemented it with "whatever-blabla" reasons. And off course I use the official KODI fork, but for Android. And I guess there is no such an option in it like "use full screen window" or similar.
Official KODI is not a "fork".  It's a 'build'.  Android is a 'platform'.  I use the Windows platform.  I can't help you with Android.  I only know the pop-up 'Press OK when Playback has ended' occurs when not using fullscreen KODI setting with external players.
Sorry and thank you at the same time for all your help. Were would I add that dose this look right? 
<playercorefactory>
    <players>
        <player name="PowerDVD" type="ExternalPlayer" audio="false" video="true">
            <filename>C:\Program Files (x86)\CyberLink\PowerDVD18\PDVDLP.exe</filename>
            <args>"{1}" D:/fullscreen /quit</args>
            <hidexbmc>false</hidexbmc>
        <hideconsole>false</hideconsole> 
        <warpcursor>none</warpcursor>                  
        </player>
    </players>
        <rules action="prepend">
            <rule filetypes="bd|ifo|vob|bdmv|mpls|iso" player="PowerDVD"/>
        </rules>
</playercorefactory>
I can't get Power DVD to not show the UI and just play the disc I can live with it. This is what I came up with to play both DVD and BD disc.

<playercorefactory>
    <players>
        <player name="PowerDVD" type="ExternalPlayer" audio="false" video="true">
            <filename>C:\Program Files (x86)\CyberLink\PowerDVD18\PDVDLP.exe</filename>
            <args>"{1}" "{D:\}"</args>
            <hidexbmc>false</hidexbmc>
        <hideconsole>false</hideconsole> 
        <warpcursor>none</warpcursor>                  
        </player>
    </players>
        <rules action="prepend">
            <rule filetypes="bd|ifo|vob|bdmv|mpls|iso" player="PowerDVD"/>
        </rules>
</playercorefactory>

As a side note in Kodi set it to play main movie and the dialog to press ok for external dose not show up on the newest nightly build. Again thanks so much for the help
Hi @brazen1 

This is in reference to Post #205

I'm setting up everything from scratch on a GTX 1080 HTPC. 

Couple of things:
  1. Am I correct in assuming that your remark, *EDIT*  I now use D3D11 / Native, was posted AFTER the Imgur pictures were posted, and therefore you are currently setting those two options as D3D11 & Native?
  2. I had downloaded and placed the "settings.bin" initial file that you provided in my MadVR folder before I started configuring MadVR Options. However, I noticed that while half the settings matched your Imgur Photos, the other half did not (they may have been default settings). This could be due to not all settings getting saved in that file, or maybe the settings you created while taking those screenshots were altered when you created the settings.bin file. So my question would be, should I rely more on your screenshot settings or the ones which were delivered in the settings.bin file?
  3. I noticed on Photo #28 in the screenshots you posted on Imgur, you defined 2 files, a "3d Enable.bat" and "3d Disable.bat", however, I don't see these files in that post, or the code to create these files. 
And I guess my last query is, since that post was last edited 10/22/18, has anything of significance changed since then (besides software versions), or are those settings still good?

Thanks much for your help!
I don't think it would work, but I could try to force "Full screen" tag somehow to get rid of the pop-up.
On the PC version is this argument line in the playercorefactory supposed to serve as what I've looking for?:

<args>"{1}" D:/fullscreen /quit</args>

Right? Or something else? I may try to add to on the Android version, and see whatever will it do or not...
Hi luci5r.

1) Yes
2) The screen shots are older and based on what madVR could do for me at the time.  The .bin I provided is a little more up to date but mainly I shared it because the profiles I use are setup for users.  The adjustments in those profiles would differ from GPU to GPU.  I use a GTX 960 4GB.  You a 1080.  You can achieve higher settings than me if you desire.
3) There was a time I was experimenting to get 3D perfect with madVR.  At that time when I played an HDR title, stereoscopic would disable in the NCP and did not turn back on automatically.  This meant a subsequent playback of a 3D title would only render 2D.  So, I created the .bats to automate the NCP toggle of stereoscopic when a 3D title started and added them to a madVR 3D profile to initiate them.  Since then, the bug was fixed and stereoscopic remains engaged during and after playing an HDR title now properly so the .bats are no longer needed nor the special profile in madVR to launch them.
4) Not really.  I have lowered some of my settings in madVR to accommodate 4k at 60Hz but I have no titles that are actually that frame rate - just test files I like to double check are still playable with my GPU considering things change.  In the end, I increase the settings back for 4k at 24Hz which is less demanding.
Hi Mount81.

The PCF modification leighdog posted that contains that argument is not for you.  That code will induce the very thing you are trying to avoid - "Press OK when Playback has ended".  leighdog added the argument thinking it would auto close PDVD.  It won't.  PDVD has no working command line arguments to close the program after watching a title so adding the argument to the PCF will have no affect afaik.  The only way I know of that will close PDVD after playback and return to KODI in focus is to Alt + F4.  Other players have auto quit/exit after playback built-in and it's simply an adjustment in the player(s) so no need to hard code.  Post your PCF.xml and your .bats along with your environment specs.  Maybe something will stand out that reveals why you get a pop-up "Press OK when Playback has ended".
Here's my playercorefactory: Link

I  still don't exactly know what .bat files are you referring to, can you explain? My media box is a Q10 Pro, Android 7, with latest 2.1.1 OFW and KODI 17.6 with Xonfluance Skin and no other fancy add-ons.

Thanks!
(2019-01-10, 17:56)brazen1 Wrote: [ -> ]Hi luci5r.

1) Yes
2) The screen shots are older and based on what madVR could do for me at the time.  The .bin I provided is a little more up to date but mainly I shared it because the profiles I use are setup for users.  The adjustments in those profiles would differ from GPU to GPU.  I use a GTX 960 4GB.  You a 1080.  You can achieve higher settings than me if you desire.
3) There was a time I was experimenting to get 3D perfect with madVR.  At that time when I played an HDR title, stereoscopic would disable in the NCP and did not turn back on automatically.  This meant a subsequent playback of a 3D title would only render 2D.  So, I created the .bats to automate the NCP toggle of stereoscopic when a 3D title started and added them to a madVR 3D profile to initiate them.  Since then, the bug was fixed and stereoscopic remains engaged during and after playing an HDR title now properly so the .bats are no longer needed nor the special profile in madVR to launch them.
4) Not really.  I have lowered some of my settings in madVR to accommodate 4k at 60Hz but I have no titles that are actually that frame rate - just test files I like to double check are still playable with my GPU considering things change.  In the end, I increase the settings back for 4k at 24Hz which is less demanding.
 @brazen1 

Thanks for your response & for clarifying!

In that case I'll revert mainly to using the settings.bin file. For the initial setup, I'm not really looking for any higher settings than the baseline you're using - I really don't think I need it (even if my GPU can support it) and I can definitely tell you, after a certain point my eyes are just not going to see the difference Smile

If you feel you may have made further changes to MadVR settings since the last time you posted the 'settings.bin', I wouldn't mind getting a newer/latest settings.bin from you - definitely makes things easier for newer MadVR users.

Good to know about the .bat files. Wanted to make sure I wasn't missing anything. 

Ah, yes, I don't believe I have any 4K @ 60hz content, so I'll stick with the 4K @ 24Hz settings. 

So after configuring everything, I'm noticing a video issue. This is going to be hard to explain but I'm going to try my best.

The best word I can describe for it would be "judder". I want to clarify, it is not the same as when you try to play 24Hz video in 60Hz. And It's not happening to all the motion on the screen. It only happens to certain motions on the screen. It's like a judder, like lag in motion. 

If you look at this screenshot below from 'Oblivion'. Imagine if Tom Cruise moves his head in this scene, there is a very prominent judder motion in his head - like you can see a vibration or repeated frames or something. But the rest of the scene is perfectly smooth. The objects around him or in the background do not experience the judder. Only certain prominent objects on screen. 

Image

This is only happening in MPC-BE/MadVR as setup per Post #205. If I play the same video in Kodi or PowerDVD, this does not happen. If I play a UHD HDR Disc in my Disc Player on the same screen, it does not happen. So it's definitely something that is limited to MPC-BE/MadVR and I'm guessing it's something in my settings. 

You guys know more about this than I do, so it may be something apparent to you guys. Appreciate any advice I can get.

Thanks!!