Kodi Community Forum

Full Version: HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
New updates for MPC-HC and LAV Filters today.
I've installed the new Windows update v.1809 and also updated nVidia drivers to the latest 416.16 editing in alternative audio drivers into the installation.  So far I have tested Audio switching, HDR switching, 3D switching, SDR, iso's and mkv's with success using MPC player method.  I have noticed DVDFab Player v.3 no longer switches into HDR mode so I'll investigate if it's the Windows update or the driver when I get more time.

Trying to salvage DVDFab Player v.3.  Substituting Windows HDR for private API's HDR isn't a good idea.  Not even in a pinch.  Windows HDR is deeply overly saturated and I don't think recalibrating is the answer.  This isn't going to bode well for DVDFab Player v.3 any longer.  In my testing, it no longer switches into HDR mode using Windows 1809 and since v.3 is no longer updated, it's a lost cause.  Last I checked, DVDFab Player v.5 isn't private API compatible and relied on Windows HDR.  That isn't going to change.  This isn't looking good.  MPC players with LAV and madVR are still switching but as I've stated before, load times are getting longer and since updating it's even longer... at least for me.  Tried old faithful older nVidia drivers and no change. 

On a good note, PDVD is still switching 3D and all is well.
(2018-10-05, 22:28)brazen1 Wrote: [ -> ]MPC players with LAV and madVR are still switching but as I've stated before, load times are getting longer and since updating it's even longer... at least for me.  Tried old faithful older nVidia drivers and no change.

@brazen1  I don't know if this is relevant, but I experience, long time now, longer and longer load times, when starting a movie with MPC-LAV-madVR combo and I have concluded that this is happening when testing, installing, uninstalling or updating nVidia drivers or versions of this programs. Then, I do a clean install of Windows and everything is working great and loading instantly. Just saying...
Having DVDFab Player go down is not good for your usage case.

I'm not sure how to help troubleshoot your issues with MPC. It takes about two seconds at most for MPC-BE to load a file when play is pressed. I see the logo once more after the resolution change (I'm sure if I like that) and then playback begins. It isn't a five to ten second process, to be certain.

Maybe it has something to do with ISO files or something being cached in Kodi or MPC. Really not sure.
I'm at 12 seconds to open an HDR title solo in Windows Explorer now with MPC.  That's with the iso already mounted.  I believe you both that it's odd.  Reloading Windows isn't really an option until it becomes absolutely necessary.  Been screwing around with DVDFab v.3 starting yesterday after updating Windows.  It simply doesn't comply with 1809.  One could use it HDR>SDR but it just isn't the same after using HDR for so long.  It's basically worthless for me at this point.  So, it's back to v.5 now.  I'll just have to play the game and turn on/off Windows HDR for it.  Tbh, the quality is still decent but I notice occasional frame drops.  V.3 doesn't.  I think it fails to use hardware acceleration since the CPU is overtaxed and the fan is whirring.  V.3 this didn't happen prior to the 1809 update.  The oversaturation went away after rebooting for some reason and hasn't returned.  Hotkeys are much easier.  3D is still whacked.  You have to switch global resolution manually from 2160p to 1080p before using or it crashes the driver.  But I already knew all this when I tested and reported about a year ago at the release.  Maybe next year they'll get it right.  In the mean time, PDVD still fills that niche.  It will continue to fill the SDR iso's menus too.  Lastly, I'm back to MPC-HC starting paused, BE is fine.  I guess fwiw, the O/S is latest, all the players are latest, drivers are latest, LAV, madVR latest, etc.  KODI v.18 next.  If the hurdles continue with no workarounds or fixes in sight, going back to 1803 and keeping KODI 17.6 is probably the only answer since ZERO problems occurred with anything.  Can't stand the thought of living in the past though but hey, if it ain't broke...
I installed KODI v.18 x64 nightly today and was met with a pleasant surprise - It's working now. 

In the past I used Estuary instead of Titan and vice versa during testing.  Now, if I use Titan, it still ends up reduced to a quarter size in the top left corner and is unresponsive after quitting an external player.  Switching to Estuary this does not occur.  I will be using Estuary until Titan is working again (if ever).  The original maintainer/designer of the skin has quit.  Perhaps someone can suggest another skin that is as highly customizable as Titan especially when it comes to vertical menus and a Netflix interface.  Though this sounds like a lot to ask, my customizing is actually very, very vanilla.  I'm not much of an eye candy guy desiring all the bells and whistles.  I just like the layouts.

So far in my limited preliminary testing, everything is much, much faster.  3D MVC switches in and out, as does HDR using iso's with PDVD, and both MPC players.  Subsequent playbacks of different players is also performing well.  Looking forward to switching over to v.18 as a daily driver now.  Please suggest skins compatible with v.18 and tia.
Aeon Nox Silvo has a vertical menu option and many different views to choose from. I don't think it can replicate the Netflix layout of Titan, though, but has been my favorite skin for some time. I even contributed a view (small icons) and the disc sliding animation for low list view for movie sets, which was ported from Aeon Nox 4.

When Aeon Nox 5 can out, many wanted some of the lost customization from Aeon Nox 4. Mike Silvo and I were two of a few who were trying to learn skinning to add these features. I quit with the .xml skinning and Mike Silvo created his own Aeon Nox 5 mod that is still maintained regularly. It is filled with options for user customization and is comparable to Titan in that way.
I would also suggest , Aeon MQ7 for Kodi v18 "Leia" or skin.aeon.madnox also this Skin for Leia  here the thread. I personally use Aeon MQ7 for Kodi v18 "Leia" that in my opinion encloses in a single mosaic the best views mod of these last periods.
(2018-10-07, 23:14)gotham_x Wrote: [ -> ]I would also suggest , Aeon MQ7 for Kodi v18 "Leia" or skin.aeon.madnox also this Skin for Leia  here the thread. I personally use Aeon MQ7 for Kodi v18 "Leia" that in my opinion encloses in a single mosaic the best views mod of these last periods.
 +1 for Aeon MQ7 for Kodi v18 Leia.

Been using it since day one of switching over to Leia months ago. Zero problems and fantastic performance.
Thanks for the suggestions.  Still undecided?  Using Estuary for a while to eliminate any problems that (may) be introduced by other skins.  Still learning how to customize Estuary especially various types of 'nodes' and how to 'vanilla' it down to my liking.  New LAV Filters out btw.
Fwiw, I have installed all the different versions of Titan.  All of them have the resolution change problem when quitting an external player and they are useless.  All of them.
Quickly switching to Estuary, the problem does not occur. 

I proceeded to try Aeon MQ7 for Kodi v18 Leia.  It too has the problem.

I then installed Aeon Nox SiLVO 5 for v.18.  It does not have the problem and works as it should.

I adjusted nothing for any of these skins.  Just installed and went directly to Avatar, played it briefly, and exited the MPC player. 
A working skin returned me to KODI in focus ready for interaction. 
A non-compliant skin reduced KODI to a quarter of its size in the top left corner and any attempt to interact resulted in a crashed app. 

Not sure how many skins I'll have to go through to find more working ones?  At least we know there is one besides Estuary.
As the RC of KODI v.18 draws nearer, perhaps many of these skins that think they are ready for prime time will update to fully working order.  Maybe not.
I suppose there could be some gremlin in my system and my system alone that prompts this behavior in some skins but I doubt it.  Nothing special going on here afaict.
in fact there is this problem change resolution with the skin Aeon MQ7 per Kodi v18 Leia , you have to kill (F4) to exit from Kodi. it happens to me too. but it is the lesser evil , taking into account what he can offer  skin mod Aeon MQ7 per Kodi v18 Leia.

anyway , if you want to test the Mod Estuary , look here :  Estuary Mod V2 for Kodi 18
I tested Estuary Mod V2 for Kodi 18 shortly after reporting the 1st batch of broken skins.  It too has the problem.  I'm not really interested in what skins offer if they don't work as they should.
I want to thank you for being honest and confirming that you too experience the problem and now I know it is not just my environment.  This MAY be completely widespread and no one knows.. much less cares.  Many more confirmations would be needed.

Add Xonfluence (Krypton v17.x & Leia v18.x) to the list of broken skins with the problem.

addonic is a working skin.
Andromeda is a working skin.
Aeon Nox Redux v.5 is a working skin.
Black Glass Nova is working.
Chroma is working.
Confluence is working.
Mimic is working.
Omni is working.
Quartz is working but focuses on the last playlist window instead of returning to the library.
Rapier is working.
Xperience1080 is working.

At this point, it appears anything in the KODI repo is working and most of the skins with their own repositories do not.
To sum it up, in my testing, all the skins in the KODI repo are working.
Although not in the KODI repo, Aeon Nox SiLVO 5 for v.18 also works.

The skins I have tried that use their own repos and do not work are:
All the different mod versions of Titan.
Aeon MQ7 for Kodi v18 Leia.
Xonfluence (Krypton v17.x & Leia v18.x)

I will not be testing any other skins that are not in the KODI repo unless a user suggests it does not have the problem after trying it themself.
Sounds pretty strange. The skin is just a container for the standard .xml calls used by Kodi. It must be a specific code syntax used by some of the skins that is causing a crash. And the debug says nothing about any errors? Sounds difficult to diagnose.