Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
BurningSky Wrote:Read the second post above yours. Oo

PS: SVN builds are only availiable in the "ppa:team-xbmc-svn/ppa" repository.

You are right. I was actually refering to "ppa:team-xbmc-svn". The above posts are not clear to me. Does it imply that there actually still no nightlies more recent than SVN28042?
Yes, we must wait until it is fixed. Alternatively, you can compile xbmc from source code or download an unofficial nightly build (search google).
BurningSky Wrote:Yes, we must wait until it is fixed. Alternatively, you can compile xbmc from source code or download an unofficial nightly build (search google).
Or use the last stable build Smile
JackieBrown Wrote:Or use the last stable build Smile

Yes, but unfortunately it is incapable of playing many m4v files smoothly. I wouldn't even have remembered to try a newer build if not for this.
Anybody try the new SVN build from the SVN PPA? Is it safe to install?
BurningSky Wrote:Yes, we must wait until it is fixed. Alternatively, you can compile xbmc from source code or download an unofficial nightly build (search google).

JackieBrown Wrote:Or use the last stable build Smile

Would prefer not to go with unofficial nightlies or compiling myself. Why should the latest stable build be more recent than the official nightlies? Isnt that against the idea of nightlies.
steve1977 Wrote:Why should the latest stable build be more recent than the official nightlies?

jackie brown didn't say this. he was just stating another possible option to get XBMC running without too much hassle. not everybody *needs* to be on SVN build status...

add.: regarding the SVN PPA, this is interesting:

[email protected]:~$ sudo apt-add-repository ppa:team-xbmc-svn/ppa
[sudo] password for XXX:
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv A292248FCB9CFB8689A30B7A2BBD133164234534
gpg: requesting key 64234534 from hkp server keyserver.ubuntu.com
gpg: key 64234534: "Launchpad PPA for XBMC SVN BUILDING" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
[email protected]:~$ sudo apt-get update
E: Type 'n' is not known on line 2 in source list /etc/apt/sources.list.d/team-xbmc-svn-ppa-lucid.list

some days ago I removed the XBMC SVN PPA due to the build problems and went to the stable repo instead by doing a ppa-purge; editing the list and deleting the "n" finally did the job... I have no idea where that "n" came from.

add.: okay, after doing some additional apt-get cleanups (xbmc-bin and xbmc-data (9.11) weren't updated due to dependency/version errors and haven't been purged/autoremoved either) I'm finally back to SVN with pre-10.5 xbmc and xbmc-live on lucid64, looking good so far!

p.s. is it supposed to be running in "windowed" mode? when I try to change this in settings, XBMC goes to the far left corner of my xscreen in a very small windows and the "windowed" option does not change, but I can change back easily. please bear in mind that I'm on ubuntu minimal with no GUI/window manager whatsoever. and one word to the devs: I LOVE what you did with the audio settings, awesome to have all these output&receiver settings now finally integrated into GUI!
I'm also finding myself stuck in Windowed mode. The System->System->Video Output->Display Mode setting is Windowed and no other setting can be selected. Even starting xbmc -fs from the commandline starts up in windowed mode.

Not sure if this is new as of svn 31181 as I had it set deliberately to Windowed in the previous version - but that was because I had been having problems with fullscreen and wanted to see if those problems were gone - they are, I can't go fullscreen at all! :-)
I have to add that in spite of the setting "windowed" my XBMC installation runs fullscreen, but that should mostly be related to my GUI-less installation.
I guess this will be fixed in next SVN build.
In XBMC settings I also see Windowed mode but I can run fullscreen. I am using a Lucid install (with a GUI). I believe there is a problem just in the label in the settings.
same thought here. else than that, the build runs just fine, so go get it, guys! Wink thanks alot for the build fix, watta!
This is perhaps a dumb question, but i can't seem to figure it out on my own..

Just reinstalled my box with a clean xbmc live 9.11, but i would like to upgrade to svn 28256 which i understand is the last stable for now.

If I add svn ppa in my sources.list i get to svn 31*** something, but I would like 28256 only.

Anyone got some tips for me ? It's a clean 9.11 live install, only nvidia drivers updated, nothing else changed.

Thanks in advance Smile
I coudn't update from 9.11 stable until i purged xbmc and reinstalled using the svn ppas. I'm running lucid x64 Bit
I am getting an interesting error while attempting to update to svn 31181 from the PPA:

Code:
dpkg: error processing /var/cache/apt/archives/xbmc-data_1%3a10.08~svn31181-karmic1_all.deb (--unpack):
trying to overwrite '/usr/share/xbmc/scripts/autoexec.py', which is also in package xbmc-scripts-example 1:10.08~svn31181-karmic1
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Processing triggers for man-db ...
Errors were encountered while processing:
/var/cache/apt/archives/xbmc-data_1%3a10.08~svn31181-karmic1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

It was suggested to try 'apt-get install -f' but that did the same thing... I also tried renaming the autoexec.py file mentioned in the error, but no luck.
i had to remove the svn ppa, then purged xbmc (sudo apt-get purge xbmc)
then installed the svn ppa again, and then installed xbmc..

seems to be running better for me, i am still getting the scrapper issue, but I think its just this build....