Kodi Community Forum

Full Version: XBMC Ubuntu PPAs (precompiled PPA builds for Ubuntu)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Any plans on making the PPA SVN builds automatic? (I'm assuing they are not at the moment, since they don't seem to be daily as advertised).
They're daily so long as SVN compiles that day. Today was not one of those days.
Aha, fair enough :p

I am going to install MythBuntu 8.04.1 desktop version i386..which one i use:


What about SVN build? What is the latest version as of today?

And a very dumb question..since i use windows all the time, how do you install linux program because with windows you open .exe what about Linux?
I am going to install MythBuntu 8.04.1 desktop version i386..do i use this


because it says Ubuntu 8.04.1 is Hardy Heron

What about SVN build? What is the latest version as of today?

And a very dumb question..since i use windows all the time, how do you install linux program because with windows you open .exe what about Linux?
You use synaptic to install almost everything. You need to add both lines to your repositories in synaptic. Just click around in the program and you will understand what I am talking about.
I haven't installed MythBuntu yet (i am going to do it tomorrow) but i am already lost. Could you link me to the file that i download at least so i can put it on usb tonight?

Btw nice choice, aeon ftw! I love that interface
@davidw89, If you aren't willing to do research on your own, maybe you should just install the win32 version? You've asked several very simple questions already that either a) belong in Ubuntu's forums, or b) are very easy to find answers to. These forums are to help you with PROBLEMS not hold your hand through the entire experience.
As usual :-)

Althekiller POWAAAA !!!

@davidw89: Seriously, you should try to read some documentation. I think I have added a link to the first post of this Thread. So, please help yourself ;-)

I think i've found a bug in the PPA builds. The web server doesn't work - also changing the configuration in the gui doesn't work, and the default port is 80 which can't be opened by a non-root user so fails.

I *think* I fixed it by chmodding the web directory (under shared) to allow the xbmc user write access into this directory, as well as changing the port to 8000.

It now responds, but I can't login as I don't know the username - only the password gets specified in the config Smile


I have no write access to the webserver directory as a user but it works for me. :/

The default configuration is clearly a problem IMHO.

I had this login issue but I don't know why, but it doesn't happen to me anymore
boba23 Wrote:Didn't check with synaptics but apt does the job, just got todays build 14184:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
xbmc xbmc-common xbmc-skin-default
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 44.5MB of archives.
After this operation, 16.4kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
xbmc xbmc-skin-default xbmc-common
Install these packages without verification [y/N]? y
Get:1 http://ppa.launchpad.net hardy/main xbmc 2.1a2svn14184-hardy1 [490kB]
Get:2 http://ppa.launchpad.net hardy/main xbmc-skin-default 2.1a2svn14184-hardy1 [13.9MB]
Get:3 http://ppa.launchpad.net hardy/main xbmc-common 2.1a2svn14184-hardy1 [30.1MB]

Could you tell me how you did this? I am trying to install it on hardy Heron!!
Which ones?

Oh, I'm so screwed.

I'd installed the latest version of xbmc using the PPAs and been running with no problems. Fired up my machine this morning and found updates waiting to be applied. Tried to run them but got the message "error authenticating some packages" and a list of four xbmc related items that couldn't be authenticated.

Went to the synaptics package manager and selected the items to update without requiring authentication and ran them with no errors, looked at the packages again and saw version 3a. Tried to run XBMC and computer complete locks up. Bigger problem is that I had xmbc to run on statup so now every time I reboot I just freeze up.

Anyone have any suggestions, please?
A bit more information about my request for help ... it seems the machine is not frozen as such, I'm able to log out, shutdown etc with key commands and the updates waiting icon appears on the Ubuntu title bar after a few minutes. Rather it appears that the latest version of xbmc updated from the PPA is starting up and not displaying properly...

So I guess the question is does anyone know of a way to kill a process in Ubuntu with key commands (an equivalent of task anger in Windows) or prevent xbmc from loading on start up?