Kodi Community Forum

Full Version: [HOW TO] KODI Linux on Amlogic TV Boxes
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Updated the Jynxbox version to 23 March

Feedback welcomed
How can I make the update without to lost my settings?
Thank you guys!
Just installed the latest XDA Release on my ATV1200 and everything works (except the Wifi Settings and the LEDs at the front).

The Wifi Settings disappeared from the menue after the installation. But I managed to connect to my Wifi network with the network manager addon.
The status led at the front is now red no matter if the box is running or not. Smile
I installed the PVR VU+ addon and I connect the Box with my first Dreambox. This works fine.
How can I connect a second Dreambox with the PVR VU+ addon?

Can I clone the addon and how can I make that?

I have two Dreamboxes, beacause I have two signal inputs, from different sat dishes.
for the new xda, which do we install on the 520?

MX_LINUX_v1.00-G18REF_MX2REF-update.zip 102.63 MB
MX_LINUX_v1.00-G18REF_MX2REF-NEWMTD-update.zip 102.64 MB

I assume the first?
Neither, you install the stvmx version
Just follow the instructions on the first page
dammit reading owns me. I'm already on xda and I just assumed it used the android recovery from usb like the RC1 version.

I already wiped my device (data and cache partitions)

I only have a usb stick , iguess I'm out of luck until I get a microSD?

nevermind found one Smile I already tried the above file with usb, got installation aborted errors.

now onto the proper way Smile

I simply use the SD card 'conversion' version with a reset boot => MX_LINUX_v1.00-STVMX-conversion.zip. I've installed XDA from both Geniatech and XDA versions. I had to re-install over XDA because I broke the SSH shell, couldn't log in with Putty.

I think that's the best way to install it, worked several times for me til I got it right.

Remember, no WIFI on the ATV520, but apparently it does work with the ATV1200.

Otherwise, everything in the XDA version seems to be working... so far.

BTW, you'll notice that you can read and write to the USB or SC cards plugged into the box. If you make a 'root' '/' entry in the smb.conf file (etc/samba/smb.conf), you can read and write to it too!

Hello guys,

I am working on a project on a Geniatech ATV1220. Basically what I want to do is when I boot the device it should boot to a basic linux, where it just loads a browser in kiosk mode to display a predefined website, where text, static images and video can be displayed. It should implement node.js for some functionality as well.

Since there is a working XBMC Linux build for that device I think it should be possible and I should be able to use a lot of existing code to do it.

Can someone please push me in the right direction as of what I need to do to get this to work?

I have UART connection to the device and can use PuTTY to connect to it. I also played around with TFTP/NFS server to load images, so I know the basics.

I have used Buildroot before but I would need matching device/board files I think to build a matching filesystem.

If anyone can help me with this task, send me a private message. It would be very much appreciated.


So far, there is no desktop Linux distribution for the Geniatech ATVs. All the Geniatech boxes have Amlogic SoCs (System on Chip). There has been a lot more work on desktop Linux for the Rockchip SoCs.

This thread details a way to dual boot desktop Linux from an SD card using the Rockchip SoC:


Because Rockchip boxes have access to a desktop Linux, they don't need a stand alone XBMC, they just use the Linux version of XBMC for Linux desktop. Since Amlogic boxes don't have a Linux desktop, folks have concentrated on stand alone Linux/XBMC versions.

If you find a functioning desktop Linux for Amlogic boxes, let us know because we would be interested.

Thank you for the input. I actually don't really need a whole functioning desktop linux environment.

I thought about just booting to a maybe webkit based custom built browser, that uses hardware acceleration, to just display one page, that is predefined in some file or can be changed by remoting into the box.
(2014-04-02, 12:45)ProTV Wrote: [ -> ]How can I make the update without to lost my settings?

Install the 'XBMC Backup' addon to save your setting. Make a backup, install the update, restore. For more details, look at my earlier posts on the subject in this thread.


The XDA version of Linux/XBMC is working pretty good. It does run a little hot compared to the Geniatech version. Has anyone else noticed that? The XDA version overclocks the Mali GPU, so this might account for that.

As for the front lights not changing or even the right colour, I have a workaround. I picked up a Micro SD to USB adopter so I could make boot cards on my XP machine. It's about the size of a Bluetooth dongle, very small. But, it has a bright blue LED built in that comes on with power and flashes during activity. Now, it's easy to tell if the ATV520 is on or not and I have a visual indicator when downloads are finished too.

installed 1.0 stable XDA last night, no issues.

I added all the addons that I commonly use, I did run into script errors when trying to flag favourites in icefilms for some reason. the addons themselves seem to work fine (aside from that favourites issue).

everything works well, the timezones work great now... it didn'treally bother me before, but now I have the correct date and time in the corner.

cant' comment on the box running hotter (I was running XDA before)... but i'll check.

with the pre RC XDA that I was using I had one occurrence where the video locked up and the audio went into endless repeat, I'm thinking it overheated, but that only happened once.

this boots faster than the previous XDA I was using, if I had to put a number on it I'd say 20% faster for sure.

I noticed the internet settings seem hidden now? when I go into internet settings I don't see the IP etc listed anymore. it grabs an IP fine so there's no concern really.

as for the lights, when I have it off, I have 1 red light. when it's on I have 1 red and 1 blue.
Does the new XDA image referred to on page 1 now support AC3 sound properly? The Jynxbox version of February does not as it causes loud cracking from my HDMI Denon Home Theatre unit. Not tried the March Jynxbox update yet for this bug though.