Kodi Community Forum

Full Version: [HOW TO] KODI Linux on Amlogic TV Boxes
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2014-01-18, 16:11)Biatsch Wrote: [ -> ]For all keys working on ir from atv1200 take this remote.conf https://www.dropbox.com/s/b3po4acd0c24tjj/remote.conf

Thanks! I actually find your conf just a second ago at xda forum, and was going to point to your config, but you you were faster. I put your remote.conf to /root/.xbmc/remote.conf, rebooted, and yes, all the buttons (except for the one with two "windows(?)) seem to work. Great!

Now the suspend is only thing not working.
Fact: I use the RC2 ( only Linux ) *.img on my ATV 1200 ,worked very well via wired lan ,

So , i want to use my database/thumbnails ( size 3 GB ) to big for internal sdcard. Is it possible to use a syslink or advancesettings to
link to my external sd card. Working with linux is new for me.

Question: If its possible , how is the correct syntax ,

thanks for help ( excuse bad english )

Mmh replace the remote config in etc/xbmc...... Button with 2windows? ...... Idont got this button on my remote ...... Igot 17buttons and all are configured in my config..... Home button is configured as exit...... Back button as delete, zoomin and zoomout are for next or previous.... chapter or track, rest like signed on button iam using rc2 from xda and suspend is working.... Ok its not really suspend its more a power off but i can power it on with remote ...... That didnt worked with geniatech release ..........

If anyone has noticed, the XDA version of Linux/XBMC won't properly set up timezone from the System/Appearance/International page.

There are two ways to fix this issue. Both require that you have a working copy of XBMC on another machine. You can collect the proper data from the Userdata/guisettings.xml file. Search for <locale> in the file, it looks like this (with your specific info instead of these defaults):

        <country>USA (12h)</country>

These are the two ways you can replace the data. You can use the 'vi' editor to edit the guisettings.xml file directly or you can use Jatho's method to open up the XBMC folder to SMB networking and alter the guisettings.xml file with you favorite word processor (don't use MS notepad). Once the file is changed to your timezone settings, reboot the box and the clock will be set to your timezone.

Here's Jatho's SMB solution:


...and here's my own adaptations to it that you might find helpfull:


Aside from not having wireless access, the XDA version of Linux/XBMC is just what I was looking for, even the power button 'Suspend' mode works just the way I want it. When I 'Suspend', the 3 port smart HDMI switch hooked up to my TV automatically switches back to my satellite box the same way my DVD player does when I switch it off.

Dumb question Smile how does one copy the conf over to Linux xbmc?
(2014-01-19, 22:19)tinker Wrote: [ -> ]These are the two ways you can replace the data. You can use the 'vi' editor to edit the guisettings.xml file directly or you can use Jatho's method to open up the XBMC folder to SMB networking and alter the guisettings.xml file with you favorite word processor (don't use MS notepad).

In fact don't EVER use a word processor on a text config file. Use a proper text editor, one that can save files in unix/win/osx mode.

For windows notepad++ is very good!

you can use the same methods above to change the guisettings.xml file to change any file. Go carefully through the posts above (and this whole thread) to get a feel for using Putty and vi. Once you set up SMB networking, you can use any file explorer (Explorer for Windows or Finder for Mac) to access the box. In my SMB post (the second link in my last post) I show how to share '/', the root folder of Linux/XBMC, over the network. That way you can have access to the whole system and use a nicer editor than vi just save the file using your file manager. There's danger in doing this. Chances are you could mess up Linux or, worse yet, brick the box completely.

Having said that, I've been careful and done my research without mishap but I also know the risk I'm taking too.



I think the XDA version is the one I'm going to stick with. Now that I've resolved the timezone issue, I can't find fault with this build. Everything works just as it should. I also like the fact that it uses the Android SPI boot code so that it's easier to revert back to Android if necessary. Has anyone tried to revert back to Android from the XDA XBMC version? My guess would be you could just choose the Android image file (the 300k one.) from the recovery menu instead of using a self-booting SD card like the Geniatech version.

Xda Linux works great! No need for remote conf,it works fine for
Me as is. Both the atv520 and my harmony work just fine.

Update. Never mind. Back Button goes to main menu. Looks like it's time for some vi edits tomorrow Smile
Is there any way to have shutdown button initiate shutdown without popping up the selection box?

Don't complain, the power button actually works now! When you turn the unit on with the remote, it boots from scratch... but it boots! I'll take it... for now. They might add a 'hibernate' mode in future releases but I'm happy with the way it works now. It doesn't take long to boot, 20 seconds, faster than the Geniatech version.

oh I'm not complaining Smile it's a great build, works fantastically.

the only reason I asked is because I use a harmony remote for everything, so when I switch inputs or power off, I don't get the opportunity to select "suspend". I do like how suspend exits xbmc so you get a fresh boot every time.
does anyone have the mediaportal PVR addon running, with me MX-Linux (RC2) always crashed
Has anyone succesfully udated from Geniatech Linux to XDA Linux RC2? I've seen posts for few unsuccesfull attemps, but not sure if anyone been successfull.

There is note that Android SPI should be updated first, and I'm not sure what it means. Can some one elaborate?

If I revert from my current Geniatech Linux first to Android following the procedure in first posting in this thread, and then flash the XDA Linux RC2, whould I be ok?

Anyone else done this?

I'm afraid I'm going to brick my box Smile That would not be good, because no I have enerythign working so nicely on my ATV520E except for suspend.

I think community supported version for Linux would be better in the long run, which is why I prefer XDA relase.
yes I believe if you follow the procedure for reverting back you should be ok.

and once you are in android, you just need to apply the update the same way you would with their android updating.

however I haven't done this. I've just gone from original geniatech to latest geniatech to XDA.
hi all

just purchased the mygica atv520E

i was using the android xbmc but wanted to try the Linux version so i followed your instructions here and loaded it. It loads and works fine, however, i have a windows 8 PC with my shared media folder (containing movies, tv shows etc) when i tru to add any of the folders i cannot. It prompts me for the username and password so i enter it but then it reprompts me like it was incorrect or something. So i removed the linux and put back the android and i was able to add my media folders. Prompted me for username and password, i entered it and it worked. Went back to Linux and it keeps prompting me.. Is there a fix for this?