Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2013-04-27, 15:26)gsjosh Wrote: [ -> ]I'm running Windows 7 with boblightd. I'm actually not sure which version. How do I check this?

Anyway, I used to have a setup that worked flawlessly on XBMC 12.0 but now that I installed 12.1 the boblight add-on isn't working properly?

It installs right, it connects to the daemon fine. There are no errors. XBMC says it has connected to the daemon and in the command prompt I see the daemon reporting " connected" and "said hello" messages.

But the lights are not showing anything, not even if I turn on the static lights in the menu. Did anybody else experience this? Anybody else running on Windows 7 who wants to point me to a working daemon?

Hi all, I have been using xbmc now for 2 years or so and had it as my default dash on my xbox for much longer :-) . this is my first post here.
I have exactly the same problem as gsjosh except i never had my leds in place for Xbmc version 12.0
I have windows 7 64bit. I can start boblightd, my 50 leds flash red, green and blue and the command window stays open. I then start Xbmc 12.1 official and "connected to boblightd" shows on the bottom right and no leds flash. (in the command window i can see boblight has connected)
I play a movie and nothing happens with the leds.
For now I am using prismatik with xbmc in "not true fullscreen" mode and it works pretty good but i would still like to see boblight working.
I find that prismatik does not smoothly fade out/in.
Anyway, if anyone could shed some light on this it would be great, many thanks in advance.
Also, im looking for a good config file for 50 leds on a 51 inch tv, running an arduino uno. (ive been searching but to no avail).
I tried this version, boblightd shuts off as soon as it starts just after running the .bat file
then boblight in xbmc has nothing to connect to
Maybe something with your configuration?
firstly, huge thanks...... your tut does work :-)
i now have beautifully flowing boblight controlled leds on my tv. :-)
now, one small isuue, when i click the start.bat i get about 4 terminal windows opening on my desktop (and red, blue and green flashs from leds),3 blank terminal windows and one terminal window telling me
C:\boblightd>MODE com3:9600,N,8,1 1>NUL

"clear is not recognised as an internal or external command, operable program or batch file.

C:\boblightd>tasklist /FI "IMAGENAME eq boblightd.exe" 2>NUL : find /I /N "boblightd,exe" 1>NUL

CTerminate batch job (Y/N)?

if i select yes it terminates (as you would expect but if i select no then it loads and is ready for the plugin and i get the red green blue again. Is there anyway to fix this so i can load it on windows startup?
I then go into xbmc official 12.1 and the plugin finds boblightd and my leds come on real fancy :-) and when i sleect a move i have working leds!!
Now i notice straight away the white on the screen come out as blue on the leds so i need to sort out the gamma stuff, but so far its great to see it working.
Thank you again Teko for taking the time to help me out, if you have any odeas that you like to try to sort out the above problem lease let me know.
Ok, after editing the batch file i now have an automatic startup when windows starts :--)

Thanks again TeKo, now, where's the reputation button?
+/- button below each post.
(2013-04-29, 23:00)philbee Wrote: [ -> ]Ok, after editing the batch file i now have an automatic startup when windows starts :--)

Thanks again TeKo, now, where's the reputation button?

What did you change to get it to work?
(2013-04-30, 15:53)TeKo Wrote: [ -> ]
(2013-04-29, 23:00)philbee Wrote: [ -> ]Ok, after editing the batch file i now have an automatic startup when windows starts :--)

Thanks again TeKo, now, where's the reputation button?

What did you change to get it to work?

i just left it like below....

MODE COM3:9600,N,8,1 >NUL

C:\boblightd\boblightd.exe -c c:\boblightd\boblight.conf -f

echo running..

(2013-04-30, 15:33)Memphiz Wrote: [ -> ]+/- button below each post.

As dumb as I might sound, I still cant see +/- .
Do i need to have a certain number of posts before they are available to me?
Hey guys

For the last couple of days I have been having problems with my arduino based boblight setup because it resets it self randomly.

When it resets i get two blue blinks (just like I would get when I turn on xbmc) and the most irritating thing is that its completely random and I still haven't found anything in the logs.

I'm running Openelec 3.0 (12.1) with the boblightd addon.

Full disclosure I am cheating a bit since I manually run boblight-x11 on boot (DISPLAY=:0.0 boblight-X11 -o saturation=1.1 -o value=2 -o threshold=10 -o interpolation=1 -o speed=24 > /dev/null 2>&1) so I get lights in the menu Wink

It has worked perfectly for months, but I have tried to rule out changes in the plugin by using the eden version but still get resets.

Maybe some of you have any theories or ideas where I could search for hints? I was wondering if maybe the arduino was running out of memory or something?

Thanks for reading my poorly written rant Smile
Edit, also happens after deleting the plugin and only using boblight-x11

Edit2 Solved! found some errors in /var/log/messages about usb disconnecting because of emi. I changed the usb cable with one that has a metallic ring one it (shielding) and the issue has gone away. Strange that I get this issue after more than a year of it working fine.
(2013-04-29, 20:06)TeKo Wrote: [ -> ]http://forum.xbmc.org/showthread.php?tid=151559

Try this version.
That did it! It is working again, thank you Smile
Hi All,

I'm having problems with my Raspberry Pi + XBMC + Boblight setup.

I'm currently using this setup"
- HTPC - Windows 7 - XBMC - LAN
- R-Pi - Occidentalis - Boblightd - LAN
- 4 x 25 ws2801 LEDS
- 5v - 4A Power adapter.

Everything is connected as per diagram: http://boblight.googlecode.com/svn/wiki/diagram.png
I've powered the LEDS at the beginning and ending of the string (not in between).

PixelPi script seems to work great , also boblight-constant works out fine.
The boblight add-on in XBMC connects fine, no errors on the deamon side even.

Still, I checked results of other people on youtube and they seem to have far better results.
The screen lights up with it should light up, my result seems kinda 'messy' and lights up at places where i think it shouldn't.

Here's a short movie of my problem:

Did anyone experience the same problem?
I have no idea why the results are so different, i'm starting to think that i should've powered all strings directly not just the beginning and the end. Or maybe the sampling percentage (20% now) is too high and i should sample only 10% of the screen for the right color of LED.

Any other ideas? Thanks gents.
@TROY ,without being an expert on this,I think something is messed up in your boblight conf.

I have a nice working boblight system with 1ardouino mega using its four channels to light 4 rgb led strips(left,top left,top right,right) at my 50" TV ,with my win7 htpc .I thing its time to upgrade it and use rgb leds for better color resolution.So I am looking for suggestions about what LEDs to use and how many.I am planning to construct a light alluminum frame for the LEDs,using vesa mount to fix it at the back of my TV.

Edit:or 2 meters of that strip should do the job http://www.adafruit.com/products/306
1st 4A is probably not enought to power 100 LEDs.

Can you post your boblight.conf?

Try setting the addon to slow for Movies instead of custom settings.
Hi Wolfgr & Teko,

Here's my boblight.conf

port 19333

name ambilight
type ws2801
output /dev/spidev0.0
channels 300
prefix 41 64 61 00 63 36
interval 20000
rate 48000
debug off

name red
rgb 0000FF
gamma 1.0
adjust 1.0
blacklevel 0.0

name green
rgb 00FF00
gamma 1.0
adjust 1.0
blacklevel 0.0

name blue
rgb FF0000
gamma 1.0
adjust 1.0
blacklevel 0.0

Here's the video again to show the problem:

I tried to pipe the output to the Popen.py script to adjust RGB values, this makes the color seem quite nice but the timing is even worse.

I also noticed that 4 LEDS are NOT working with this Boblight config.
The first led in the bottom left is working, then 4 are not working.
This is weird because when i do a boblight-constant they don't seem to work either.

Is there something wrong in my setup? I counted 100 LEDS , that's what i'm pretty positive about Smile

Update: I've been testing with the ADAfruit LED pixel script and it seems that only the last led isn't working in this script
Here's a video:

In XBMC (using boblight) the last 4 leds aren't working.