Kodi Community Forum

Full Version: LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Definitely frame skipping with #0801 not sure when it started, need to check. Will report back.
Playback until true end of file has been reached - IS WORKING!

I was surprised, that this is working with milhouse testbuilds, I tried 618 and 714. Is this a bug or a feature? Is it going to stay?

What am I talking about?

In Kodi 16, the length of a video file was only checked at the beginning of the playback. If the file size increased during playback (due to ongoing recording or something like that), the playback stopped at the initial length, ignoring the remaining "new" data. I talked to some devs about this feature and they said, it is planned for Kodi 18. (280437 (thread))

However it already works with milhouse testbuilds. At least on my PI2. Can somone confirm this as well? I am not using any PVR addon, I just have a SMB share, which contains movie files which I added to the Kodi Video section and sometimes these files grow due to ongoing recordings (not controlled by Kodi) - and with milhouse testbuilds I can watch movies to the very end, even though they where still recording when I started to watch them.

Was this added by milhouse on purpose, or is it just working by chance? Can someone else confirm this?
(2016-08-03, 00:55)popcornmix Wrote: [ -> ]
(2016-08-02, 22:24)doldi Wrote: [ -> ]hmm, only temporarily, a little better but after 10 seconds stuttering begins.

What does
vcgencmd get_throttled
report after you have had stuttering?

hi popcornmix, sorry if it's a little to late ;-)

pi3:~ # vcgencmd get_throttled

[after swirch network to 1Gb/s]

thanks for your help.

Edit: Switch back to 100Mb/s and pi reboots and hangs on Kodi startlogo.
(2016-08-03, 19:31)doldi Wrote: [ -> ]Edit: Switch back to 100Mb/s and pi reboots and hangs on Kodi startlogo.

Whole device hang or just Kodi - do you have network, can you ping the device, can you login with ssh and upload kodi.log/dmesg/journalctl etc.?
(2016-07-31, 19:41)Milhouse Wrote: [ -> ]If you had a button/key mapped to CodecInfo, now map this to PlayerDebug and you should get the same functionality.
I cannot find "PlayerDebug" anywhere in the AddOn "Keymap Editor".
Am I right in assuming that Keymap Editor would need an update to add "PlayerDebug"?
yes, i've network and can reboot/halt ect over ssh.
think kodi would hangup.

Milhouse - only if i switch the router backward from 1G to 100Mb/s.

btw...i am not alone with pi3 stuttering on video h264, oscm forum also some people are not happy with the pi 3.
They make the same prozedure like me , sd cards from pi2 to pi3, backwards ect.
(2016-08-03, 20:52)jd17 Wrote: [ -> ]Am I right in assuming that Keymap Editor would need an update to add "PlayerDebug"?

Yes. Just replace CodecInfo with PlayerDebug in whatever *.xml the Keymap Editor creates.
@dodli: Originally you said 1Gbit was the problem and 100Mbit was fine:

(2016-08-02, 20:11)doldi Wrote: [ -> ]If i switch the LAN port on my Fritz!Box7490 to Power Mode =1 Gbit/s, videos would not play without stuttering - on Green Mode = 100 bit/s it's ok.

With my two peaces of Raspberry Pi2, video plays always perfect on both Mode.

but now 100Mbit is crashing Kodi? Hard to say what the cause of Kodi not starting is without the requested logs. Are you waiting for MySQL Wake-on-LAN or something similar?

I have an RPi3 here connected to a Netgear DGND4000 over wired Cat5/1GBit and there are no problems streaming over smb:// from a Windows 7 Pro PC (also connected via wired Cat5/1GBit). I have also tested with:
in advancedsettings.xml and it worked as expected, buffering up to 7.5MB, and still no stutter.

When did this problem start, with #0801?
my pi3 is connected to Fritzbox7490, OS=windows 10 share over samba (7meters networkcable). I think, if i switch from 1G to 100mb/s on playing video,
my Fritzbox disconnect for 1-2 sec and kodi reboots.

boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 quiet


advancedsettings.xml is:

The problem is precent since i have my pi3 build '#0708 - all my pi2 works perfect also in PowerMode 1Gb/s - but i think i have to speak now about this Problem and my pi3 is for the dustbin, yes.

pi3 is nothing for h264 (?), sorry i'm glad about this little peace of s**t. :-)
(2016-08-03, 22:45)doldi Wrote: [ -> ]boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 quiet

This should be one line!

really weird thing with the PI3, I have almost the same configuration as you.
But my PI3 is not overclocked, which is advancedsettings.xml and config.txt not modified all standard values. The best is that PI3 is connected to the router (FB7490) via wireless and I have no problems with either x264 still with XviD. As a server running a Pi2 with openmediavault and is connected to the router via LAN cable.

my config.txt content:

New LibreELEC.tv Krypton build #0803: RPi / RPi2
(Supercedes previous build)

# uname -a
Linux rpi512 4.7.0 #1 Wed Aug 3 22:21:01 BST 2016 armv6l GNU/Linux

# vcgencmd version
Jul 28 2016 12:46:32
Copyright (c) 2012 Broadcom
version e12916091ba9d68ef2780e4e142ade56aa301754 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160803221747-#0803-g32f35d3 [Build #0803]

# vcdbg log msg 2>&1 | grep DTOK
002392.571: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (32f35d3d, changelog) and tip of XBMC master (b04140e5, changelog) with the following modifications: Build Highlights:
  1. Added to newclock5: PR:10216 player: make playspeed floating point and add tempo controls
  2. Added to newclock5: PR:10222 VideoPlayer: write state of clocksync to ProcessInfo, make FinishPipeline dependent on this
Build Details:
  1. LibreELEC.tv:
    • kodi: Fix green screen on Generic (PR:598, 1 commit, 1 file changed)
    • projects/imx6/linux: disable kernel NTFS support (PR:601, 1 commit, 1 file changed)
    • dispmanx_vnc: build with linux 4.7 rpi libraries (PR:602, 1 commit, 3 files changed)
    • Fix build of AML-based projects after updating to Krypton Alpha3 (PR:603, 3 commits, 20 files changed)
    • spotify-connect-web: initial addon (PR:580, 1 commit, 8 files changed)
  2. XBMC:
    • [Socket] fix port assignments (PR:10220, 1 commit, 1 file changed)
    • [droid] show correct labels of plugged USB drives (PR:10209, 1 commit, 13 files changed)
    • [linux] fix datadir (KODI_HOME) detection (PR:10217, 1 commit, 1 file changed)
    • listproviders: fix segfault introduced by 2702a31f6dc1e9b6d9aaab56bc5… (PR:10223, 1 commit, 2 files changed)
    • [droid] remove google-breakpad (PR:10226, 1 commit, 3 files changed)
  3. pvr.vdr.vnsi:
    • drop -1 from list of priorities (PR:86, 1 commit, 1 file changed)
  4. newclock5:
    • New commits in this build:
      • VideoPlayer: consider clock speed when enabling clockSync (673856e5)
      • VideoPlayer: write clockSync state to ProcessInfo (5ddd0cac)
      • render: only call FinishPipeline if clocksync is active (7c7cd0b8)
      • settings: Add settings option to control atempo resampling (87b03056)
      • player: make playspeed floating point (525e621d)
      • player: add tempoup and tempodown to player controls (36fb90d5)
      • player: add gui labels for tempo (37e13a69)
      • VideoPlayer: only enable tempo for non-realtime streams if sync playback to display is enabled (cb0a5424)
    • Commits no longer in build:
      • Hacky scheme to enable accelerated playback as first ff step (670c2da5)
      • rbp: Disable atempo filter when gpu resampling is enabled (7d734696)
  5. Additional commits/pull requests/changes not yet merged upstream:
sound like your switching while pi is on and your playing Video.
not a good idea, as would screw up network, and Kodi would glitch as sudden loss of data.

If your switching between 1gb and 100mb after powering down the pi, then I've got it wrong.
Note: The webserver may be disabled by default since #0802b (it used to be enabled by default). This will be corrected in #0804.
These builds include faster/slower playback (from 75% normal speed up to 155% of normal speed).
You will need to add a remote mapping. E.g.
      <f mod="ctrl">xbmc.playercontrol(tempoup)</f>
      <r mod="ctrl">xbmc.playercontrol(tempodown)</r>
The atempo filter means no chipmunk voices when playing fast.