Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
With subtitles set to none, I also get the same error with the new xbmc build.

Here's a log from a fresh start until the error selecting a stream.


Edit: fixed it myself. It seems Python didn't like the lower case t on "true" in line 530 of /lib/iplayer2.py, so I changed it to "True" and it works. Using Python 2.7.6.
Submitted a couple of patches against http://code.google.com/p/xbmc-iplayerv2/...rt=&id=132

Patched against current 2.5.7 build

This should fix the issue with grabbing/playing subtites. At least, it does for me !

First post here. iPlayer 2.5.7 script fails on RPi with Gotham when trying to play any program.
Log file is here at xbmc logs
I have emptied cache. Tried to force resume lock release but this fails.

A later quick edit:
I know nothing about Python but I just blindly commented out lines 830 to 835 in default.py (previously, I tried subtitles none in settings which failed but I left it like that) and it immediately worked.
Can those that were getting errors when using subtitles (and some when not) try this version


works ok on my system with subtitles, but I could have missed something. Contains some optimisations too as well as changes to the resume functionality (in terms of how often resume points are made)
This works on videos, thank you !
But still script error on live streams if subtitles option is not set to off.
Good call. I missed that. Will fix, probably via dlakes fix. Cheers
I haven't used the addon for ages, I have set the video streams to 2800k but appears as SD, is it the way it should be ? thanks.
(2014-05-13, 03:52)fondary Wrote: [ -> ]I haven't used the addon for ages, I have set the video streams to 2800k but appears as SD, is it the way it should be ? thanks.

I can guess, or you could provide a log Smile

My guess is that programme isn't available as HD. You don't need to mess with video stream bitrate btw, leave as auto. If your screen res is high enough, it will choose the highest bitrate available.

v2.5.8 released - https://drive.google.com/file/d/0B_knGio...sp=sharing

Hopefully the subtitle bug is resolved.

* subtitle fixes
* resume point improvements - thanks to neil
* regular expression optimisations - thanks to neil
You are right ! That was Doctor Who, not in HD, Nor live streams unfortunately

2.5.8 working great for me (Win 7 32 Frodo).

I am getting a 'Dependancies not met' error whilst trying to install the Add On from Zip file I downloaded from your official page onto Gotham.

I have posted the log file here - http://xbmclogs.com/show.php?id=201699

Any help appreciated, this was pretty much my favourite App before I updated to Gotham.

Try updating your script.module.elementtree as it's out of date. You should be on version 1.2.8 if you're using Gotham, but it looks like you're on an older version which is the problem:
01:04:35 T:3008527104   DEBUG: GetZipList - Processing zip://%2fmedia%2fDATAWRITE%2f_xbmc%2fiPlayer-v2.5.8.zip/
01:04:36 T:3008527104   DEBUG: Addon script.module.elementtree requires xbmc.python version 2.0 which is not available

Note entirely sure where script.module.elementtree is from - I'd imagine it's from one of the standard repositories but I've no idea how you might have installed it - although I found a link to a current zip here.
Thanks MilhouseVH,

I'm still a bit stuck though. How do I update the script.module.elementtree?

I first tried downloading the zip file you linked to and then doing an 'Install From Zip' but nothing happened. And I still got the error.

I did a quick Google on how to update the script.module.elementtree and got a few results back saying that i needed to place the file in the 'addon' folder. Is this correct?

I tried setting Filezilla to access my ATV1 directly but am failing at setting that up (not sure why). I've always just used an USB stick to install Addons i downloaded on my mac in the past.

Sorry if these are basic questions.

ssh in, rm -fr ~/.xbmc/addons/script.module.elementtree, then install from zip - should work.
Ok, so I managed to get access via Filezilla FTP client, but when i tried to overwrite the existing files within the script.module.elementtree directory within XBMC I got a 'permission denied' error.

So i did a bit more Googling and found the following instructions to 'fix' my old version of script.module.elementtree:

==== from here - http://www.xbmchub.com/forums/threads/14...sh-install =====

To run this fix you need to install the binary highway addon here is how:
Goto home screen->system->addons->install from zip->fusion->video->free-tv->repository.thehighway

After you install the repo here is the path:
Goto homescreen->videos->getmore->the binary highway->context menu and makesure the addon is installed and enabled

After you install/enablel that :
homescreen->videos->the binary highway->misc(tools and such)-> updater v2b[git]-> click "click to update the file for updates".

homescreen->videos->the binary highway->misc(tools and such)-> updater v2b[git]-> tools_XBMC_fixes[2013-10-20b].zip (click on it)

Need to back out one level or:
homescreen->videos->the binary highway->misc(tools and such)->XBMC FIXES [2013-10-20]->install: script.modual.elementtree (click on the blue type)


Unfortunately that didn't seem to fix the issue. From my untrained eye it looks as though the script.modual.elementtree is still not up-to-date? Here's the latest logfile: http://xbmclogs.com/show.php?id=202034

(2014-05-15, 16:34)MilhouseVH Wrote: [ -> ]ssh in, rm -fr ~/.xbmc/addons/script.module.elementtree, then install from zip - should work.

Sorry, I missed reading this (as I had old version of page open while I tried to fix). How do I 'ssh in'?

Do I do that via terminal on my mac?
(2014-05-15, 17:10)micsten Wrote: [ -> ]Do I do that via terminal on my mac?

Yes. Or since your XBMC is installed on Ubuntu, just open the Ubuntu terminal app and type away.