Kodi Community Forum

Full Version: Titan M O D ( last Updated 24-04-2019)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2018-12-28, 11:32)Keksebacker Wrote: [ -> ]2/ Remaining duration of live tv
The remaining duration of live tv doesn't work correctly in the osd.
For every other content like movies or netflix and so on it works properly.
Also in the small channel list its shown correctly.
 I made some changes to fix this ill leave the code here along with other small changes all for live tv.:

-Included the season and episode details if available.
-If no channel logo was available the channel details would shift left.
-Fixed EPG Runtime. KODI 18 only

Controls changed in IncludesOSD.xml name="OSDInfoPanelNetflix":
Code:

                <!-- details info --><!-- OSDLabel9 -->
                <control type="label">
                    <width>1000</width>
                    <height>45</height>
                    <align>left</align>
                    <font>Light24</font>
                    <textcolor>white</textcolor>
                    <shadowcolor>dimgray</shadowcolor>
                    <label>$VAR[OSDLabel9]</label>
                    <visible>!VideoPlayer.Content(movies)</visible>
                    <scroll>false</scroll>
                </control>
Variables changed in IncludesOSD.xml
Code:

    <variable name="OSDImage">
        <value condition="![VideoPlayer.Content(livetv) + Skin.HasSetting(NoPvrArtOSD)] + !String.IsEmpty(Window(Home).Property(SkinHelper.Player.AnimatedPoster))">$INFO[Window(Home).Property(SkinHelper.Player.AnimatedPoster)]</value>
        <value condition="![VideoPlayer.Content(livetv) + Skin.HasSetting(NoPvrArtOSD)] + !String.IsEmpty(Player.Art(tvshow.poster))">$INFO[Player.Art(tvshow.poster)]</value>
        <value condition="![VideoPlayer.Content(livetv) + Skin.HasSetting(NoPvrArtOSD)] + !String.IsEmpty(Player.Art(poster))">$INFO[Player.Art(poster)]</value>
        <value condition="![VideoPlayer.Content(livetv) + Skin.HasSetting(NoPvrArtOSD)] + !String.IsEmpty(Window(Home).Property(SkinHelper.Player.Art.Poster))">$INFO[Window(Home).Property(SkinHelper.Player.Art.Poster)]</value>
        <value condition="VideoPlayer.Content(livetv) + !String.IsEmpty(VideoPlayer.Cover) + String.Contains(VideoPlayer.Cover,DefaultVideo)"></value>
        <value condition="!String.IsEmpty(VideoPlayer.Cover)">$INFO[VideoPlayer.Cover]</value>
        <value condition="!String.IsEmpty(Player.Icon)">$INFO[Player.Icon]</value>
        <value>DefaultVideo.png</value>
     </variable>
    <variable name="OSDLabel7">
        <value condition="Player.HasVideo + String.IsEqual(Window(Home).Property(subtitlemenu), show)"></value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv)">$INFO[VideoPlayer.ChannelNumberLabel,, • ]$INFO[VideoPlayer.ChannelName]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + Player.IsInternetStream + !String.IsEmpty(Window(Home).Property(SkinHelper.Player.AddonName)) + String.IsEmpty(VideoPlayer.TvShowTitle)">$INFO[Window(Home).Property(SkinHelper.Player.AddonName)]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(episodes) + !String.IsEmpty(VideoPlayer.TvShowTitle)">$INFO[VideoPlayer.TVShowTitle]</value>
        <value condition="Player.HasAudio + !String.IsEmpty(Window(Home).Property(SkinHelper.Player.AddonName))">$INFO[Window(Home).Property(SkinHelper.Player.AddonName)]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show)">$INFO[VideoPlayer.Title]</value>
        <value>$LOCALIZE[31040]</value>
    </variable>

    <variable name="OSDLabel8">
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(Episodes)">$INFO[VideoPlayer.Season,$LOCALIZE[20373] , | ]$INFO[VideoPlayer.Episode,$LOCALIZE[20359] , | ]$INFO[VideoPlayer.Title]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(Movies)">$INFO[VideoPlayer.year]$INFO[VideoPlayer.Mpaa, | ,]$INFO[VideoPlayer.Duration(mins), | ,min]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + [!String.IsEmpty(VideoPlayer.Season) + !String.IsEmpty(VideoPlayer.Episode) + !String.IsEmpty(VideoPlayer.EpisodeName)]">$INFO[VideoPlayer.Title] - S$INFO[VideoPlayer.Season]E$INFO[VideoPlayer.Episode] - $INFO[VideoPlayer.EpisodeName]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + [!String.IsEmpty(VideoPlayer.Episode) + !String.IsEmpty(VideoPlayer.EpisodeName)]">$INFO[VideoPlayer.Title] - E$INFO[VideoPlayer.Episode] - $INFO[VideoPlayer.EpisodeName]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + [!String.IsEmpty(VideoPlayer.EpisodeName)]">$INFO[VideoPlayer.Title] - $INFO[VideoPlayer.EpisodeName]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + [!String.IsEmpty(VideoPlayer.Title)]">$INFO[VideoPlayer.Title]</value>
    </variable>

    <variable name="OSDLabel9">
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + !String.IsEqual(PVR.EpgEventDuration(mins),0) + VideoPlayer.HasEpg">$INFO[PVR.EpgEventDuration(mins)]min</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv)"></value>
        <value>$VAR[premiered_or_year]$INFO[VideoPlayer.Mpaa, | ,]$INFO[VideoPlayer.Duration(mins), | ,min]</value>
    </variable>
(2018-12-17, 22:16)Shadowmage952 Wrote: [ -> ]I'm was wondering if it is possible to add an option to disable the sliding/hiding of the main menu when you shift over to the widgets when in the modern vertical mode.  I'm looking for a static screen that allows you to shift from the menu to the widgets and back without it hiding and/or without any animations.

I'd love to see this option as well. Not a fan of the sliding.
(2018-12-31, 14:42)vik6869 Wrote: [ -> ]
(2018-12-28, 11:32)Keksebacker Wrote: [ -> ]2/ Remaining duration of live tv
The remaining duration of live tv doesn't work correctly in the osd.
For every other content like movies or netflix and so on it works properly.
Also in the small channel list its shown correctly.
 I made some changes to fix this ill leave the code here along with other small changes all for live tv.:

-Included the season and episode details if available.
-If no channel logo was available the channel details would shift left.
-Fixed EPG Runtime. KODI 18 only

Controls changed in IncludesOSD.xml name="OSDInfoPanelNetflix":
Code:

                <!-- details info --><!-- OSDLabel9 -->
                <control type="label">
                    <width>1000</width>
                    <height>45</height>
                    <align>left</align>
                    <font>Light24</font>
                    <textcolor>white</textcolor>
                    <shadowcolor>dimgray</shadowcolor>
                    <label>$VAR[OSDLabel9]</label>
                    <visible>!VideoPlayer.Content(movies)</visible>
                    <scroll>false</scroll>
                </control>
Variables changed in IncludesOSD.xml
Code:

    <variable name="OSDImage">
        <value condition="![VideoPlayer.Content(livetv) + Skin.HasSetting(NoPvrArtOSD)] + !String.IsEmpty(Window(Home).Property(SkinHelper.Player.AnimatedPoster))">$INFO[Window(Home).Property(SkinHelper.Player.AnimatedPoster)]</value>
        <value condition="![VideoPlayer.Content(livetv) + Skin.HasSetting(NoPvrArtOSD)] + !String.IsEmpty(Player.Art(tvshow.poster))">$INFO[Player.Art(tvshow.poster)]</value>
        <value condition="![VideoPlayer.Content(livetv) + Skin.HasSetting(NoPvrArtOSD)] + !String.IsEmpty(Player.Art(poster))">$INFO[Player.Art(poster)]</value>
        <value condition="![VideoPlayer.Content(livetv) + Skin.HasSetting(NoPvrArtOSD)] + !String.IsEmpty(Window(Home).Property(SkinHelper.Player.Art.Poster))">$INFO[Window(Home).Property(SkinHelper.Player.Art.Poster)]</value>
        <value condition="VideoPlayer.Content(livetv) + !String.IsEmpty(VideoPlayer.Cover) + String.Contains(VideoPlayer.Cover,DefaultVideo)"></value>
        <value condition="!String.IsEmpty(VideoPlayer.Cover)">$INFO[VideoPlayer.Cover]</value>
        <value condition="!String.IsEmpty(Player.Icon)">$INFO[Player.Icon]</value>
        <value>DefaultVideo.png</value>
     </variable>
    <variable name="OSDLabel7">
        <value condition="Player.HasVideo + String.IsEqual(Window(Home).Property(subtitlemenu), show)"></value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv)">$INFO[VideoPlayer.ChannelNumberLabel,, • ]$INFO[VideoPlayer.ChannelName]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + Player.IsInternetStream + !String.IsEmpty(Window(Home).Property(SkinHelper.Player.AddonName)) + String.IsEmpty(VideoPlayer.TvShowTitle)">$INFO[Window(Home).Property(SkinHelper.Player.AddonName)]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(episodes) + !String.IsEmpty(VideoPlayer.TvShowTitle)">$INFO[VideoPlayer.TVShowTitle]</value>
        <value condition="Player.HasAudio + !String.IsEmpty(Window(Home).Property(SkinHelper.Player.AddonName))">$INFO[Window(Home).Property(SkinHelper.Player.AddonName)]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show)">$INFO[VideoPlayer.Title]</value>
        <value>$LOCALIZE[31040]</value>
    </variable>

    <variable name="OSDLabel8">
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(Episodes)">$INFO[VideoPlayer.Season,$LOCALIZE[20373] , | ]$INFO[VideoPlayer.Episode,$LOCALIZE[20359] , | ]$INFO[VideoPlayer.Title]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(Movies)">$INFO[VideoPlayer.year]$INFO[VideoPlayer.Mpaa, | ,]$INFO[VideoPlayer.Duration(mins), | ,min]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + [!String.IsEmpty(VideoPlayer.Season) + !String.IsEmpty(VideoPlayer.Episode) + !String.IsEmpty(VideoPlayer.EpisodeName)]">$INFO[VideoPlayer.Title] - S$INFO[VideoPlayer.Season]E$INFO[VideoPlayer.Episode] - $INFO[VideoPlayer.EpisodeName]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + [!String.IsEmpty(VideoPlayer.Episode) + !String.IsEmpty(VideoPlayer.EpisodeName)]">$INFO[VideoPlayer.Title] - E$INFO[VideoPlayer.Episode] - $INFO[VideoPlayer.EpisodeName]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + [!String.IsEmpty(VideoPlayer.EpisodeName)]">$INFO[VideoPlayer.Title] - $INFO[VideoPlayer.EpisodeName]</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + [!String.IsEmpty(VideoPlayer.Title)]">$INFO[VideoPlayer.Title]</value>
    </variable>

    <variable name="OSDLabel9">
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv) + !String.IsEqual(PVR.EpgEventDuration(mins),0) + VideoPlayer.HasEpg">$INFO[PVR.EpgEventDuration(mins)]min</value>
        <value condition="Player.HasVideo + !String.IsEqual(Window(Home).Property(subtitlemenu), show) + VideoPlayer.Content(livetv)"></value>
        <value>$VAR[premiered_or_year]$INFO[VideoPlayer.Mpaa, | ,]$INFO[VideoPlayer.Duration(mins), | ,min]</value>
    </variable>
 
 By test some thing on PVR, i need to ask some things .As i work just with an demo client, and maybe i got something wrong.

But since playing time on PVR/Live TV  is fine on my end i need to locate the mentioned issues more.

1st.
Whats the difference on your end when you start watch TV , if you start with "switch" or "play programme" Huh
Is there anything different showing up on your side.
Also as i am a non PVR user, whats the main difference between theese 2 options?
Any benefits in comparison ?

(if I start with  "play programme" :  VideoPlayer.Content(livetv) is false,
 if I start with "switch" :                 VideoPlayer.Content(livetv) is true)
but booth shows me correct playing time/remainning time values in the actual version

2st.
PVR.EpgEvent**** Labels are only for PVR Events, in my case there is a planned recordring at a specific time.
So $INFO[PVR.EpgEventRemainingTime] - doesnt show the value of currently playing video , it shows the "remaining time" till the next EPG EVENT (record, end record ) will start
and that sounds logical to me.
But the wiki says
Quote:" PVR.EpgEventRemainingTime[(format)]Returns the remaining time for currently playing epg event....
Hi

There is an issue with setting Video Sources for Movie submenus on the home screen . From what I can see it has always been there.
If I go to Configure shortctuts -> Edit menu shortcuts on Movies then select Customise Subemenu -> Add I can choose the Sources as a submenu from Video Library. But when I do choose a video source it get's listed twice. If I choose 2 video sources I get 4 items, item 1 listed twice and item 2 listed twice and so on. How can I fix this?
(2019-01-04, 14:09)E net Wrote: [ -> ]Hi

There is an issue with setting Video Sources for Movie submenus on the home screen . From what I can see it has always been there.
If I go to Configure shortctuts -> Edit menu shortcuts on Movies then select Customise Subemenu -> Add I can choose the Sources as a submenu from Video Library. But when I do choose a video source it get's listed twice. If I choose 2 video sources I get 4 items, item 1 listed twice and item 2 listed twice and so on. How can I fix this?

Need to take a look, didnt noticed it as i dont used that option.
(2019-01-04, 14:11)mardukL Wrote: [ -> ]
(2019-01-04, 14:09)E net Wrote: [ -> ]Hi

There is an issue with setting Video Sources for Movie submenus on the home screen . From what I can see it has always been there.
If I go to Configure shortctuts -> Edit menu shortcuts on Movies then select Customise Subemenu -> Add I can choose the Sources as a submenu from Video Library. But when I do choose a video source it get's listed twice. If I choose 2 video sources I get 4 items, item 1 listed twice and item 2 listed twice and so on. How can I fix this?

Need to take a look, didnt noticed it as i dont used that option. 
Thanks Smile
(2019-01-04, 12:08)mardukL Wrote: [ -> ] By test some thing on PVR, i need to ask some things .As i work just with an demo client, and maybe i got something wrong.

But since playing time on PVR/Live TV  is fine on my end i need to locate the mentioned issues more.

1st.
Whats the difference on your end when you start watch TV , if you start with "switch" or "play programme" Huh
Is there anything different showing up on your side.
Also as i am a non PVR user, whats the main difference between theese 2 options?
Any benefits in comparison ?

(if I start with  "play programme" :  VideoPlayer.Content(livetv) is false,
 if I start with "switch" :                 VideoPlayer.Content(livetv) is true)
but booth shows me correct playing time/remainning time values in the actual version

2st.
PVR.EpgEvent**** Labels are only for PVR Events, in my case there is a planned recordring at a specific time.
So $INFO[PVR.EpgEventRemainingTime] - doesnt show the value of currently playing video , it shows the "remaining time" till the next EPG EVENT (record, end record ) will start
and that sounds logical to me.
But the wiki says
Quote:" PVR.EpgEventRemainingTime[(format)]Returns the remaining time for currently playing epg event....
  
1.  I am not sure where these options are.  As far as i know its always switch.  Is play programme for recordings?  I dont know i dont record.  I only see options for switch and program information.  Also want to clarify we are ONLY talking about OSDInfoPanelNetflix (screenshot provided) in the includesOSD.xml I havent spotted any other problem in the views i use.
The OSD runtime was reporting 0 and would increment as you keep watching the channel.   In other words VideoPlayer.Duration is reporting your current playtime instead of runtime of EPG event. I have made a change to clearly illustrate the problem and differences between both variables.

-In this first shot the PVR.EpgEventDuration reporting 155 correctly while VideoPlayer.Duration reports 0 (the current play time)

Image

-After 2 minutes watching the movie, the PVR.EpgEventDuration reporting 155 correctly while VideoPlayer.Duration reports 2 (the current play time)

Image

2.  I dont think PVR event means PVR recording, it could mean the current epg you are in.  I see other variables specifically regarding recordings PVR.TVNowRecording...
Also, I added a progress indicator to the netflix OSD but need help placing it.  The progress bar, border, and duration should be horizontal and not vertical.

Here is my current IncludesOSD.xml

https://pastebin.com/B6C7j9rM

And IncludesOSDDialogs.xml

https://pastebin.com/PdJW17av

Image
(2019-01-05, 00:40)vik6869 Wrote: [ -> ]Also, I added a progress indicator to the netflix OSD but need help placing it.  The progress bar, border, and duration should be horizontal and not vertical.

Here is my current IncludesOSD.xml

https://pastebin.com/B6C7j9rM

And IncludesOSDDialogs.xml

https://pastebin.com/PdJW17av

Image

Ok.thanks for bring that up.
I will post pm next time related to this.
To clear some things.
hope i have time next week.
Hi. Thanks for the great skin.

Running on librelec.

Small issues

Wehn I press the left toggle on the home screen the power menu isn't showing up at the bottom like previous Titan skins in krypton. Am I missing something?

Also when I do get the power menu up and access settings. It flicks me right back to the home screen. Settings works if I access it via another shortcut bit not the power menu

Thanks for your help
(2019-01-06, 08:13)jezza1222 Wrote: [ -> ]Hi. Thanks for the great skin.

Running on librelec.

Small issues

Wehn I press the left toggle on the home screen the power menu isn't showing up at the bottom like previous Titan skins in krypton. Am I missing something?

Also when I do get the power menu up and access settings. It flicks me right back to the home screen. Settings works if I access it via another shortcut bit not the power menu

Thanks for your help

I changed the vertical layout , click left is focus submenu and right will focus widgets.and click "back" should open the shutdown menu.
Im aware of that bug, that settings will autoclose itself , but didnt resolved it.

I like to keep that navigation, but but add the titan default behaviour (without the bounce slide and fullscreen widgets ) soon.
Awesome. Thanks for the quick reply. Thanks the back button helps but the autoclose is a bummer. Let me know when it's fixed.

Also when I use live tv and I push say 9 for button 9 the on screen display has gone. It does change channels but your kind of changing blind.

Thanks for keeping this skin alive. Easily the best livetv and pvr menu's
(2019-01-06, 12:49)jezza1222 Wrote: [ -> ]Awesome. Thanks for the quick reply. Thanks the back button helps but the autoclose is a bummer. Let me know when it's fixed.

Also when I use live tv and I push say 9 for button 9 the on screen display has gone. It does change channels but your kind of changing blind.

Thanks for keeping this skin alive. Easily the best livetv and pvr menu's

Its also reported, not fixed.but will be .
There was a change for leia in kodi related to it and looks i forget something there...

Did you also have the bug, where it shows incorrect remaining time in osd when watching live tv/use pvr?
Thanks for this mod.

I have a problem with movies and tv shows titles. It doesn't show title art (clearlogo its called?). I have to config something to make it work? It shows normal letters.
Hello!
Thanks for this mod is awesome.
I have a problem with the extrafanarts, they do not change. I have all the images along with the movies named according to the wiki poster.jpg, discart.png, fanart.jpg, fanart1.jpg and so on. All are shown but the fanarts do not change. I do not use Artwork Beef.In other skins it works perfectly.
Forgive my English. Use Google translator
Thank you very much for the hard work