Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I don't know if this problem has been posted here, but I've googled everywhere and can't seem to solve my problem.

Awhile ago, google was spamming me to signup a google+ youtube account everytime I posted a comment. I finally caved in a created one, because it was getting annoying. It then split my account into two, one with all my history and subscriptions that I renamed, and the other a blank with my email address as the username.

This creates all sorts of problems when logging in. When I sign in with the xbmc youtube addon it logs in to the blank account, although in the youtube settings I have it set to default to the main one when logging in. I tried logging in with the google+ email directly associated with the main account, but I always get a Login Failed error.

What do i do?
I'm not sure what has changed, but this just suddenly started.

I do a search for videos with the youtube plugin and none of the search results will work. My subscriptions still work but no search results.

is anyone else having this issue?
I have a problem with the playlists not showing in my account even if i am connected with my username and password.I click on playlists nothing shows up. I tried in all different devices that have xbmc. no luck so far. I would be grateful if anyone can help me solve this issue.
Yup. I have the same issue.
The existing searches show up, and clicking on the search pulls up the old results (I assume from cache).
New searches fail... I'm on the March 5th Gotham nightly build for Windows.

(2014-03-07, 09:14)MrsAngelD Wrote: [ -> ]I'm not sure what has changed, but this just suddenly started.

I do a search for videos with the youtube plugin and none of the search results will work. My subscriptions still work but no search results.

is anyone else having this issue?
(2014-01-28, 20:58)Berre Wrote: [ -> ]I finally got the plugin to work again, by manually authenticating it, and writing the authentication token to the settings file.
My solution isn't easy, but i'll try to explain it.

1. open the following url to authenticate the youtube plugin with your google account:

This will send you to a page which gives you an authentication code.

2. Create an HTML file with the following contents, and open it in a browser:

3. paste the code from step 1 in the code field and click submit
This should give you a result like this:
"access_token" : "A long cryptic phrase",
"token_type" : "Bearer",
"expires_in" : 3600,
"refresh_token" : "Another cryptic phrase"

4. open the settings.xml file in your "userdata\addon_data\plugin.video.youtube" folder
find the oauth2_access_token setting and copy the access_token phrase from step 3 to the value field
find the oauth2_refresh_token setting and copy the refresh_token phrase from step 3 to the value field
for the oauth2_expires_at setting see step 5

5. Go to http://pythonwebconsole.thomnichols.org/ and run the following script
import time

print "time.time(): %f " % time.time()

This will output something like:
time.time(): 1390933738.478000

add 3600 to that number, eg. 1390937338.478000

paste that number in the value field of the oauth2_expires_at setting.

6. Save the settings.xml file

7. the plugin should now work... it did for me.

This worked wonderful, thanks so much!

I followed your tutorial and got it to work. However, it takes about three minutes to open a stream now.

Is anybody else having this issue?

Thank you guys for your brilliant help!

same problem here: many videos do not work.

Try this:

1 - open search form and type 'weezer'

2 - try to play the first 1-5 videos (ie: "Weezer - Buddy Holly)"

3 - nothing happens

Yesterday I was having no issues with the plugin, today it seems it does not want to log on, giving a "login failed - false" error; Am I the only one who's experiencing this?

EDIT: I tried the Fix from Berre: http://forum.xbmc.org/showthread.php?tid...pid1646500 - and I am logged in again. The login on the plugin doesn't seem to be working properly.
I have looked in my xbmc folder, but i dont seem to have "addons/plugin.video.youtube" folder

You tube works fine, but cant get vevo videos to work.

any ideas
(2014-02-26, 09:16)jsnj Wrote: [ -> ]
(2014-02-19, 23:53)wiper2 Wrote: [ -> ]Hi, try this http://ulozto.net/xSvJm6MB/youtube-fix-zip. It's working for me.
Copy files from archive to ../addons/plugin.video.youtube

youtube login is only username (not email address)
vevo video working fine

Xbian 1.0RC1
Youtube plugin 4.4.6

Thanks for this. Worked. I did, however, have to use my email address as login. So it must depend on the account whether the address or just username is needed. Thanks again.

I have done this fix as well and it works perfectly for VEVO videos but keeps failing when attempt to watch "The Young Turks" Live stream. It worked about a month ago but it just keeps failing.

EDIT: I attempted to switch back to the normal YouTubePlayer.py (had it backed up) and TYT Live works, yet VEVO doesn't work. Yet it does seem to randomly stop at times, which can get aggravating.
Hey guys.

Trying to finish this but the


Link dosent seem to work ??

Found an alternative..


Thanks guys.. Allot of work to get it going.. but this is a core feature of XBMC for me so happy its now fixed.
Man, I had internet problems last night and problem with this laptop (K55n), it ended up being a problem with AT&T's DHCP server... Anyway my YouTube which had been working flawless for the last 6-8 months will not let me log-in my account. My Google Accounts are not linked...

I tried the longish fix above and not sure where to put the code generated by the link above (not the pastebin). I put the pastebin link in Notepad and made it a HTML file, put the code generated by Google where I thought it should be, but I get various error messages like I didn't do it right.

Any suggestions?

I'm having an error when sending a video from youtube to my xbmc. First, I was unable to log from the plugin, but I manage to get in.

Here is my log file

Thank you in advance.