Kodi Community Forum

Full Version: [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
@woodside,

Would like your visualization as you have all the artist information together ...
    è addon or skin?
(2014-11-20, 22:59)iorifly Wrote: [ -> ]@woodside,

Would like your visualization as you have all the artist information together ...
    è addon or skin?

It's an addon I'm in the process of developing. Glad you like it. But ya ain't seen nothing yet. It will pack a big punch when I'm through.
@woodside,
Very cool, continue .... Let us know ... more
here a video to show you what happening here with youtube addon.
i'm playing a video from the playlist suggested from learningit.



1st attempt: video played on youtube from browser with an ITALIAN IP. video is played.
2nd attempt: same video played from browser with a US IP. video is played.
3rd attempt: same video played from xbmc addon with a US IP. video is played.
4th and last attempt: same video played from xbmc addon with an ITALIAN IP. video fails

for woodside as you can see i played video directly and with an US ip it works.

thats is my experience i hope someone found a solution to fix it.
thanks a lot.
Peppe
(2014-11-21, 11:23)peppe_sr Wrote: [ -> ]here a video to show you what happening here with youtube addon.
i'm playing a video from the playlist suggested from learningit.



1st attempt: video played on youtube from browser with an ITALIAN IP. video is played.
2nd attempt: same video played from browser with a US IP. video is played.
3rd attempt: same video played from xbmc addon with a US IP. video is played.
4th and last attempt: same video played from xbmc addon with an ITALIAN IP. video fails

for woodside as you can see i played video directly and with an US ip it works.

thats is my experience i hope someone found a solution to fix it.
thanks a lot.
Peppe

And yet you post no logs.
as you should seen i already posted a bit of post before.
i think you read just last post. Wink
nothing changed from that log to this video.
Code:
16:39:24 T:3540   ERROR: CDVDPlayer::OpenInputStream - error opening [https://r1---sn-upnj5appu5-4jve.googlevideo.com/videoplayback?mm=31&ratebypass=yes&mime=video/mp4&requiressl=yes&source=youtube&sver=3&expire=1416519537&mv=m&mt=1416497823&ms=au&fexp=907259,927622,931354,931987,932404,941399,943909,945067,947209,947215,948124,952302,952605,952706,952901,953912,957103,957105,957201&sparams=gcr,id,initcwndbps,ip,ipbits,itag,mime,mm,ms,mv,ratebypass,requiressl,source,upn,expire&ipbits=0&ip=217.133.113.232&initcwndbps=710000&itag=22&gcr=it&upn=ZpiQtfmt2sA&key=yt5&id=o-ABFBptmMlg3MQbnxCxuNqqItTmDj15fKCsy1lHYn6NVV&signature=|User-Agent=Mozilla%2F5.0+%28Windows+NT+6.2%3B+Win64%3B+x64%3B+rv%3A16.0.1%29+Gecko%2F20121011+Firefox%2F16.0.1]

Because it burns so hard right into my eyes...the signature is missing completely!?! Unusual for vevo videos. Even normal ones provide a signature (not like vevo). This seems to be a problem of the addon. The addon also won't play age restricted videos (tested with the last Sin City trailer - even with an existing login).
great bromix, but i'm a bit confused.
i can play age restricted video with and without log in.
why if i use my official ip the addon fails end if i use a fake one it works?
if can be useful here is the log generated during the test i posted on youtube.
Peppe

p.s. i'm hoping in your addon.
peppe_sr, I try playing same video Of Monsters and Men, using vevo and work fine here in Brazil.

Look my post in XBMC Brasil forum about youtube, vevo update I used here, and work for me, have link for download. For log in vevo, first I authorize via Facebook Media script by ruuk, only after addon work fine for me, using my playlist with success too. Issue know, have error in Staff Picks and tradings (error 500) top playlist have same error, all other items work fine (features, premieres, touring etc).

Vevo I changed default.py and facebook.py files, for work, youtube is the actual release by learningit.

http://www.xbmcbrasil.net/showthread.php...&pid=13249
Not trying to hijack - I believe that the vevo addon 1080 update referred to in the previous post by Wanilton is the one from my git. It has been pushed to Moneymaker's git, which is where all future updates will be found. Please see this post: 1842037 (post)
Hey
Why can I only access my Youtube playlists, if my youtube channel is connected to Google+?

edit: in my youtube account I can switch between two users: My youtube username and my google email address. I can manage playlists without problems when I'm logged in with my username, but unfortunately they don't appear in the XBMC addon. If I want to create a playlist with my email address account, I have to create a Google+ profile. But then the addon works...

Any solution for this?
(2014-11-21, 11:23)peppe_sr Wrote: [ -> ]here a video to show you what happening here with youtube addon.
i'm playing a video from the playlist suggested from learningit.



1st attempt: video played on youtube from browser with an ITALIAN IP. video is played.
2nd attempt: same video played from browser with a US IP. video is played.
3rd attempt: same video played from xbmc addon with a US IP. video is played.
4th and last attempt: same video played from xbmc addon with an ITALIAN IP. video fails

for woodside as you can see i played video directly and with an US ip it works.

thats is my experience i hope someone found a solution to fix it.
thanks a lot.
Peppe
Yes the same, but I change 2 files learningit.
thankyou Wanilton but i have the vevo addon already working.
thing that is annoying me is that i use often the youtubemusic addon from addonscriptor.de that is inusable at the moment.
Peppe
Here in London the VEVO YT videos are still not playing with the add-on since the last couple of days. Has anyone succeeded yet in producing a difference log (or a new YouTubePlayer.py file) to reflect the new signature codes being used by Google in their javascript code?

Thanks in anticipation,

Regards